2005-10-19 [colin] 1.9.15cvs75
[claws.git] / src / Makefile.am
index 5e6672421074f77e9a9fbe133d23073108fcb02a..aa606339100e56eb8a0fe3750cc16b9530e3feaa 100644 (file)
@@ -1,14 +1,14 @@
-SUBDIRS = common gtk plugins
+SUBDIRS = common gtk plugins etpan
 
-bin_PROGRAMS = sylpheed
+bin_PROGRAMS = sylpheed-claws
 
-sylpheed_SOURCES = \
+sylpheed_claws_SOURCES = \
        account.c \
        action.c \
-       addr_compl.c \
        addrbook.c \
        addrcache.c \
        addrclip.c \
+       addr_compl.c \
        addressadd.c \
        addressbook.c \
        addrgather.c \
@@ -18,6 +18,7 @@ sylpheed_SOURCES = \
        addrquery.c \
        addrselect.c \
        alertpanel.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -27,8 +28,8 @@ sylpheed_SOURCES = \
        editbook.c \
        editgroup.c \
        editjpilot.c \
-       editldap.c \
        editldap_basedn.c \
+       editldap.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -40,24 +41,28 @@ sylpheed_SOURCES = \
        folder.c \
        folder_item_prefs.c \
        foldersel.c \
+       folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
+       image_viewer.c \
        imap.c \
+       imap_gtk.c \
        import.c \
        importldif.c \
        importmutt.c \
        importpine.c \
        inc.c \
-       inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       logwindow.c \
+       localfolder.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -65,70 +70,82 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mbox_folder.c \
        message_search.c \
        messageview.c \
        mh.c \
+       mh_gtk.c \
        mimeview.c \
        msgcache.c \
        mutt.c \
        news.c \
+       news_gtk.c \
        noticeview.c \
-       passphrase.c \
+       partial_download.c \
        pine.c \
        pop.c \
        prefs_account.c \
        prefs_actions.c \
        prefs_common.c \
+       prefs_compose_writing.c \
        prefs_customheader.c \
        prefs_display_header.c \
-       prefs_filtering.c \
+       prefs_ext_prog.c \
        prefs_filtering_action.c \
+       prefs_filtering.c \
        prefs_folder_item.c \
+       prefs_fonts.c \
        prefs_gtk.c \
+       prefs_image_viewer.c \
        prefs_matcher.c \
-       prefs_scoring.c \
+       prefs_message.c \
+       prefs_msg_colors.c \
+       prefs_other.c \
+       prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
+       prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
+       prefs_themes.c \
        prefs_toolbar.c \
+       prefs_wrapping.c \
+       privacy.c \
        procheader.c \
        procmime.c \
        procmsg.c \
-       progressdialog.c \
        quote_fmt.c \
        quote_fmt_lex.l \
        quote_fmt_parse.y \
        recv.c \
-       rfc2015.c \
-       scoring.c \
-       select-keys.c \
+       remotefolder.c \
        send_message.c \
        setup.c \
-       sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
        stock_pixmap.c \
-       string_match.c \
        summary_search.c \
        summaryview.c \
        textview.c \
        toolbar.c \
        undo.c \
        unmime.c \
-       vcard.c
+       vcard.c \
+       wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+sylpheed_clawsincludedir = $(pkgincludedir)
+sylpheed_clawsinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
-       addr_compl.h \
        addrbook.h \
        addrcache.h \
        addrclip.h \
+       addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -139,6 +156,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -148,8 +166,8 @@ sylpheedinclude_HEADERS = \
        editbook.h \
        editgroup.h \
        editjpilot.h \
-       editldap.h \
        editldap_basedn.h \
+       editldap.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -161,24 +179,28 @@ sylpheedinclude_HEADERS = \
        folder.h \
        folder_item_prefs.h \
        foldersel.h \
+       folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
+       image_viewer.h \
        imap.h \
+       imap_gtk.h \
        import.h \
        importldif.h \
        importmutt.h \
        importpine.h \
        inc.h \
-       inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       logwindow.h \
+       localfolder.h \
        main.h \
        mainwindow.h \
        manual.h \
@@ -187,59 +209,70 @@ sylpheedinclude_HEADERS = \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
        mbox.h \
-       mbox_folder.h \
        message_search.h \
        messageview.h \
        mh.h \
+       mh_gtk.h \
        mimeview.h \
        msgcache.h \
        mutt.h \
        news.h \
+       news_gtk.h \
        noticeview.h \
-       passphrase.h \
+       partial_download.h \
        pine.h \
        pop.h \
        prefs_account.h \
        prefs_actions.h \
        prefs_common.h \
+       prefs_compose_writing.h \
        prefs_customheader.h \
        prefs_display_header.h \
-       prefs_filtering.h \
+       prefs_ext_prog.h \
        prefs_filtering_action.h \
+       prefs_filtering.h \
        prefs_folder_item.h \
+       prefs_fonts.h \
        prefs_gtk.h \
+       prefs_image_viewer.h \
        prefs_matcher.h \
-       prefs_scoring.h \
+       prefs_message.h \
+       prefs_msg_colors.h \
+       prefs_other.h \
+       prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
+       prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
+       prefs_themes.h \
        prefs_toolbar.h \
+       prefs_wrapping.h \
+       privacy.h \
        procheader.h \
        procmime.h \
        procmsg.h \
-       progressdialog.h \
        quote_fmt.h \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
        recv.h \
-       rfc2015.h \
-       scoring.h \
-       select-keys.h \
+       remotefolder.h \
        send_message.h \
        setup.h \
-       sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
        stock_pixmap.h \
-       string_match.h \
        summary_search.h \
        summaryview.h \
        textview.h \
        toolbar.h \
        undo.h \
        unmime.h \
-       vcard.h
+       vcard.h \
+       wizard.h
 
 BUILT_SOURCES = \
        matcher_parser_parse.h \
@@ -253,21 +286,23 @@ EXTRA_DIST = \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clip_gpg_signed.xpm \
        pixmaps/close.xpm \
        pixmaps/complete.xpm \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
-       pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_noselect.xpm \
+        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
-       pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
@@ -279,6 +314,7 @@ EXTRA_DIST = \
        pixmaps/key.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
+       pixmaps/linewrapcurrent.xpm \
        pixmaps/locked.xpm \
        pixmaps/mail_attach.xpm \
        pixmaps/mail_compose.xpm \
@@ -292,16 +328,10 @@ EXTRA_DIST = \
        pixmaps/mail_send.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
-       pixmaps/messageview_text.xpm \
-       pixmaps/mime_application_octet_stream.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -311,34 +341,61 @@ EXTRA_DIST = \
        pixmaps/notice_error.xpm \
        pixmaps/notice_note.xpm \
        pixmaps/notice_warn.xpm \
+       pixmaps/offline.xpm \
+       pixmaps/online.xpm \
        pixmaps/outbox_hrm.xpm \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
+       pixmaps/privacy_emblem_encrypted.xpm \
+       pixmaps/privacy_emblem_failed.xpm \
+       pixmaps/privacy_emblem_passed.xpm \
+       pixmaps/privacy_emblem_signed.xpm \
+       pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
-       pixmaps/regular.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/sylpheed_icon.xpm \
        pixmaps/sylpheed_logo.xpm \
        pixmaps/sylpheed.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
+       pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
-       pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
        -Icommon \
        -Igtk \
-       -I$(top_srcdir)/intl
+       -Ietpan
 
-sylpheed_LDFLAGS = \
+sylpheed_claws_LDFLAGS = \
        -export-dynamic
 
-sylpheed_LDADD = \
+sylpheed_claws_LDADD = \
+       etpan/libsylpheedetpan.la \
        gtk/libsylpheedgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
@@ -346,10 +403,16 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
-       $(LIBICONV)
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
+       $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
+       $(LIBICONV) \
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -358,6 +421,15 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
+       
 AM_YFLAGS = -d