2008-10-09 [colin] 3.6.0cvs20
[claws.git] / src / Makefile.am
index 8a867b5a4c07c36d8e456674d942488845aaf088..a7fb69cf20c961d8773d070bc4e43fd5a9e93057 100644 (file)
@@ -1,32 +1,54 @@
 
-if SYLPHEED_LIBETPAN
+if CLAWS_LIBETPAN
 etpan_dir = etpan
-etpan_library = etpan/libsylpheedetpan.la
+etpan_library = etpan/libclawsetpan.la
 else
 etpan_dir =
 etpan_library = 
 endif
 
-SUBDIRS = common gtk plugins $(etpan_dir)
+SUBDIRS = common gtk $(etpan_dir) . plugins
 
-bin_PROGRAMS = sylpheed-claws
+bin_PROGRAMS = claws-mail
+install-exec-hook:
+       @rm -f $(DESTDIR)$(bindir)/sylpheed-claws
+       @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
-sylpheed_claws_SOURCES = \
+if PLATFORM_WIN32
+LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.o : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+claws_mail_res_ldflag = -Wl,w32-resource.o
+claws_mail_deps = w32-resource.o
+else
+claws_mail_res_ldflag =
+claws_mail_deps =
+endif
+
+claws_mail_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
        addrcache.c \
        addrclip.c \
        addr_compl.c \
+       addrcustomattr.c \
        addressadd.c \
        addressbook.c \
+       addressbook_foldersel.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
        addritem.c \
        addrquery.c \
        addrselect.c \
+       addrduplicates.c \
        alertpanel.c \
+       autofaces.c \
        browseldap.c \
        codeconv.c \
        compose.c \
@@ -34,11 +56,13 @@ sylpheed_claws_SOURCES = \
        customheader.c \
        displayheader.c \
        editaddress.c \
+       editaddress_other_attributes_ldap.c \
        editbook.c \
        editgroup.c \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
+       edittags.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -69,6 +93,7 @@ sylpheed_claws_SOURCES = \
        ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
+       ldapupdate.c \
        ldaputil.c \
        ldif.c \
        localfolder.c \
@@ -105,6 +130,7 @@ sylpheed_claws_SOURCES = \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_image_viewer.c \
+       prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
        prefs_msg_colors.c \
@@ -115,11 +141,13 @@ sylpheed_claws_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
        prefs_wrapping.c \
+       printing.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -142,11 +170,12 @@ sylpheed_claws_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       uri_opener.c \
        vcard.c \
        wizard.c
 
-sylpheed_clawsincludedir = $(pkgincludedir)
-sylpheed_clawsinclude_HEADERS = \
+claws_mailincludedir = $(pkgincludedir)
+claws_mailinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -155,8 +184,10 @@ sylpheed_clawsinclude_HEADERS = \
        addrclip.h \
        addr_compl.h \
        addrdefs.h \
+       addrcustomattr.h \
        addressadd.h \
        addressbook.h \
+       addressbook_foldersel.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
@@ -164,7 +195,9 @@ sylpheed_clawsinclude_HEADERS = \
        addritem.h \
        addrquery.h \
        addrselect.h \
+       addrduplicates.h \
        alertpanel.h \
+       autofaces.h \
        browseldap.h \
        codeconv.h \
        compose.h \
@@ -172,11 +205,13 @@ sylpheed_clawsinclude_HEADERS = \
        customheader.h \
        displayheader.h \
        editaddress.h \
+       editaddress_other_attributes_ldap.h \
        editbook.h \
        editgroup.h \
        editjpilot.h \
        editldap_basedn.h \
        editldap.h \
+       edittags.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -207,6 +242,7 @@ sylpheed_clawsinclude_HEADERS = \
        ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
+       ldapupdate.h \
        ldaputil.h \
        ldif.h \
        localfolder.h \
@@ -244,6 +280,7 @@ sylpheed_clawsinclude_HEADERS = \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_image_viewer.h \
+       prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
        prefs_msg_colors.h \
@@ -254,11 +291,13 @@ sylpheed_clawsinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
        prefs_wrapping.h \
+       printing.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -280,6 +319,7 @@ sylpheed_clawsinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       uri_opener.h \
        vcard.h \
        wizard.h
 
@@ -288,39 +328,59 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
+       w32-logo.ico w32-resource.rc \
+       pixmaps/addr_one.xpm \
+       pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
+       pixmaps/anonymous.xpm \
        pixmaps/book.xpm \
+       pixmaps/cancel.xpm \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
+       pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail_logo-small.xpm \
+       pixmaps/claws-mail.xpm \
        pixmaps/clip.xpm \
        pixmaps/clip_gpg_signed.xpm \
        pixmaps/close.xpm \
        pixmaps/complete.xpm \
        pixmaps/continue.xpm \
+       pixmaps/delete_btn.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
+       pixmaps/dir_close_hrm.xpm \
        pixmaps/dir_noselect.xpm \
-        pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
+       pixmaps/drafts_close.xpm \
+       pixmaps/drafts_open.xpm \
+       pixmaps/edit_extern.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
+       pixmaps/go_folders.xpm \
        pixmaps/group.xpm \
+       pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inbox_hrm.xpm \
-       pixmaps/inbox.xpm \
+       pixmaps/inbox_open_hrm.xpm \
+       pixmaps/inbox_open.xpm \
+       pixmaps/inbox_close_hrm.xpm \
+       pixmaps/inbox_close.xpm \
        pixmaps/interface.xpm \
+       pixmaps/insert_file.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
+       pixmaps/key_gpg_signed.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
        pixmaps/linewrapcurrent.xpm \
@@ -332,17 +392,24 @@ EXTRA_DIST = \
        pixmaps/mail_receive.xpm \
        pixmaps/mail_reply_to_all.xpm \
        pixmaps/mail_reply_to_author.xpm \
+       pixmaps/mail_reply_to_list.xpm \
        pixmaps/mail_reply.xpm \
        pixmaps/mail_send_queue.xpm \
        pixmaps/mail_send.xpm \
+       pixmaps/mail_sign.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_message.xpm \
+       pixmaps/mime_pdf.xpm \
+       pixmaps/mime_ps.xpm \
+       pixmaps/mime_calendar.xpm \
+       pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
+       pixmaps/mime_text_patch.xpm \
        pixmaps/mime_text_plain.xpm \
        pixmaps/mime_unknown.xpm \
        pixmaps/news_compose.xpm \
@@ -352,10 +419,18 @@ EXTRA_DIST = \
        pixmaps/notice_warn.xpm \
        pixmaps/offline.xpm \
        pixmaps/online.xpm \
-       pixmaps/outbox_hrm.xpm \
-       pixmaps/outbox.xpm \
+       pixmaps/open_mail.xpm \
+       pixmaps/outbox_close.xpm \
+       pixmaps/outbox_close_hrm.xpm \
+       pixmaps/outbox_open.xpm \
+       pixmaps/outbox_open_hrm.xpm \
+       pixmaps/outbox_close_mark.xpm \
+       pixmaps/outbox_close_hrm_mark.xpm \
+       pixmaps/outbox_open_mark.xpm \
+       pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -368,12 +443,20 @@ EXTRA_DIST = \
        pixmaps/privacy_emblem_signed.xpm \
        pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
+       pixmaps/queue_close.xpm \
+       pixmaps/queue_close_hrm.xpm \
+       pixmaps/queue_close_hrm_mark.xpm \
+       pixmaps/queue_close_mark.xpm \
+       pixmaps/queue_open.xpm \
+       pixmaps/queue_open_hrm.xpm \
+       pixmaps/queue_open_hrm_mark.xpm \
+       pixmaps/queue_open_mark.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
-       pixmaps/sylpheed_icon.xpm \
-       pixmaps/sylpheed_logo.xpm \
-       pixmaps/sylpheed.xpm \
+       pixmaps/selection.xpm \
+       pixmaps/spam.xpm \
+       pixmaps/spam_btn.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/trash_btn.xpm \
@@ -382,21 +465,36 @@ EXTRA_DIST = \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
        pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_close_hrm_mark.xpm \
        pixmaps/dir_open_hrm_mark.xpm \
        pixmaps/dir_open_mark.xpm \
        pixmaps/drafts_close_mark.xpm \
        pixmaps/drafts_open_mark.xpm \
-       pixmaps/inbox_hrm_mark.xpm \
-       pixmaps/inbox_mark.xpm \
-       pixmaps/outbox_hrm_mark.xpm \
-       pixmaps/outbox_mark.xpm \
+       pixmaps/inbox_open_hrm_mark.xpm \
+       pixmaps/inbox_open_mark.xpm \
+       pixmaps/inbox_close_hrm_mark.xpm \
+       pixmaps/inbox_close_mark.xpm \
        pixmaps/trash_hrm_mark.xpm \
        pixmaps/trash_mark.xpm \
+       pixmaps/moved.xpm \
+       pixmaps/copied.xpm \
+       pixmaps/watchthread.xpm \
+       pixmaps/tray_newmail.offline.xpm \
+       pixmaps/tray_newmail.xpm \
+       pixmaps/tray_newmarkedmail.offline.xpm \
+       pixmaps/tray_newmarkedmail.xpm \
+       pixmaps/tray_nomail.offline.xpm \
+       pixmaps/tray_nomail.xpm \
+       pixmaps/tray_unreadmail.offline.xpm \
+       pixmaps/tray_unreadmail.xpm \
+       pixmaps/tray_unreadmarkedmail.offline.xpm \
+       pixmaps/tray_unreadmarkedmail.xpm \
        pixmaps/empty.xpm
 
 
 INCLUDES = \
        -I$(srcdir)/common \
+       -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
@@ -406,44 +504,77 @@ else
 arch_ldflags :=
 endif
 
-sylpheed_claws_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic
+claws_mail_LDFLAGS = \
+       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
 
-sylpheed_claws_LDADD = \
+claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
-       gtk/libsylpheedgtk.la \
-       $(ASPELL_LIBS) \
+       gtk/libclawsgtk.la
+
+claws_mail_LDADD = \
+       $(etpan_library) \
+       gtk/libclawsgtk.la \
+       $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
        $(GNOMEPRINT_LIBS) \
+       $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
-       $(LIBETPAN_LIBS)
+       $(LIBETPAN_LIBS) \
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS) \
+       $(DBUS_LIBS)
+
+pixmapdir=$(datadir)/icons/hicolor/48x48/apps
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
+       -DG_LOG_DOMAIN=\"Claws-Mail\" \
        -DLOCALEDIR=\""$(localedir)"\" \
+       -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
-       $(ASPELL_CFLAGS) \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(OPENSSL_CFLAGS) \
        $(GNOMEPRINT_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       -Wno-unused-function
-        
+       $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
+       $(DBUS_CFLAGS) \
+  $(NETWORKMANAGER_SUPPORT_CFLAGS)
+
 #no-unused-function is there because of bison stuff
 #no-deprecated-declarations because of gpgme_data_rewind, which we have
 #to call inside gpgme due to our lack of LARGEFILE support
 
 AM_YFLAGS = -d
+
+if CYGWIN
+claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+       @rm -f claws-mail$(EXEEXT)
+       @rm -f claws-mail.def claws-mail.base claws-mail.exp libclaws-mail.a .libs/libclaws-mail.a
+       $(LINK) -shared $(claws_mailLDFLAGS) -Wl,--out-implib=libclaws-mail.a -Wl,--export-all-symbols,--exclude-symbols,main $(claws_mail_OBJECTS) -Wl,--no-whole-archive $(claws_mail_LDADD) $(LIBS)
+       dlltool --output-def claws-mail.def --dllname claws-mail$(EXEEXT) --export-all-symbols --exclude-symbols main $(claws_mail_OBJECTS) gtk/.libs/libclawsgtk.a
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,--base-file,claws-mail.base $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+       sleep 5
+       dlltool --base-file claws-mail.base --input-def claws-mail.def --output-exp claws-mail.exp
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,claws-mail.exp $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+       @cp libclaws-mail.a .libs/libclaws-mail.a
+else
+#claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+#      @rm -f claws-mail$(EXEEXT)
+#      $(LINK) $(claws_mail_LDFLAGS) $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+endif