fix `make dist`
[claws.git] / src / Makefile.am
index e5bd012f72004aa43b0a79043b3758d35caa1b46..a5d76ea27c71526e1c611f756a88f87b1840da31 100644 (file)
@@ -1,3 +1,7 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
 if CLAWS_LIBETPAN
 etpan_dir = etpan
@@ -16,7 +20,7 @@ install-exec-hook:
 
 if PLATFORM_WIN32
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -29,9 +33,9 @@ claws_mail_res_ldflag =
 claws_mail_deps =
 endif
 
-new_abook_source = \
+alt_abook_source = \
        addressbook-dbus.c
-old_abook_source = \
+orig_abook_source = \
        addrbook.c \
        addrclip.c \
        addrcustomattr.c \
@@ -69,12 +73,12 @@ old_abook_source = \
        pine.c \
        vcard.c
 
-if BUILD_NEWADDRBOOK
-abook_source = $(new_abook_source)
-abook_extra = $(old_abook_source)
+if BUILD_ALTADDRBOOK
+abook_source = $(alt_abook_source)
+abook_extra = $(orig_abook_source)
 else
-abook_source = $(old_abook_source)
-abook_extra = $(new_abook_source)
+abook_source = $(orig_abook_source)
+abook_extra = $(alt_abook_source)
 endif
 
 abook_headers = \
@@ -130,6 +134,7 @@ claws_mail_SOURCES = \
        advsearch.c \
        alertpanel.c \
        autofaces.c \
+       avatars.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -171,6 +176,9 @@ claws_mail_SOURCES = \
        news_gtk.c \
        noticeview.c \
        partial_download.c \
+       password.c \
+       password_gtk.c \
+       passwordstore.c \
        pop.c \
        prefs_account.c \
        prefs_actions.c \
@@ -188,6 +196,7 @@ claws_mail_SOURCES = \
        prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
+       prefs_migration.c \
        prefs_msg_colors.c \
        prefs_other.c \
        prefs_quote.c \
@@ -214,7 +223,6 @@ claws_mail_SOURCES = \
        remotefolder.c \
        send_message.c \
        setup.c \
-       simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
@@ -244,6 +252,7 @@ claws_mailinclude_HEADERS = \
        advsearch.h \
        alertpanel.h \
        autofaces.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -286,6 +295,9 @@ claws_mailinclude_HEADERS = \
        news_gtk.h \
        noticeview.h \
        partial_download.h \
+       password.h \
+       password_gtk.h \
+       passwordstore.h \
        pop.h \
        prefs_account.h \
        prefs_actions.h \
@@ -303,6 +315,7 @@ claws_mailinclude_HEADERS = \
        prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
+       prefs_migration.h \
        prefs_msg_colors.h \
        prefs_other.h \
        prefs_quote.h \
@@ -351,7 +364,7 @@ BUILT_SOURCES = \
        client-bindings.h
 
 client-bindings.h: claws-contacts.xml
-if BUILD_NEWADDRBOOK
+if BUILD_ALTADDRBOOK
        dbus-binding-tool --prefix=abook --mode=glib-client --output=$@ claws-contacts.xml
 
 CLEANFILES = \
@@ -374,6 +387,7 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_icon_64.xpm \
        pixmaps/claws-mail_compose_logo.xpm \
        pixmaps/claws-mail_logo.xpm \
        pixmaps/claws-mail_logo-small.xpm \
@@ -387,9 +401,14 @@ EXTRA_DIST = \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
        pixmaps/dir_close_hrm.xpm \
-       pixmaps/dir_noselect.xpm \
        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
+       pixmaps/dir_noselect_close.xpm \
+       pixmaps/dir_noselect_close_mark.xpm \
+       pixmaps/dir_noselect_open.xpm \
+       pixmaps/dir_subs_close_mark.xpm \
+       pixmaps/dir_subs_close.xpm \
+       pixmaps/dir_subs_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
@@ -527,20 +546,14 @@ EXTRA_DIST = \
        $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
-if PLATFORM_WIN32
-arch_ldflags := -export-all-symbols
-else
-arch_ldflags :=
-endif
-
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+       $(claws_mail_res_ldflag)
 
 claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
@@ -552,7 +565,6 @@ claws_mail_LDADD = \
        $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
@@ -572,12 +584,13 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(IFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
+       $(GNUTLS_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \