fix `make dist`
[claws.git] / src / Makefile.am
index 37d173f4382f66996ec170946d43d64d69b16374..a5d76ea27c71526e1c611f756a88f87b1840da31 100644 (file)
@@ -1,3 +1,7 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
 if CLAWS_LIBETPAN
 etpan_dir = etpan
@@ -7,7 +11,7 @@ etpan_dir =
 etpan_library = 
 endif
 
-SUBDIRS = common gtk $(etpan_dir) . plugins
+SUBDIRS = common gtk $(etpan_dir) . plugins 
 
 bin_PROGRAMS = claws-mail
 install-exec-hook:
@@ -15,8 +19,8 @@ install-exec-hook:
        @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
 if PLATFORM_WIN32
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -29,32 +33,19 @@ claws_mail_res_ldflag =
 claws_mail_deps =
 endif
 
-claws_mail_SOURCES = \
-       account.c \
-       action.c \
+alt_abook_source = \
+       addressbook-dbus.c
+orig_abook_source = \
        addrbook.c \
-       addrcache.c \
        addrclip.c \
-       addr_compl.c \
        addrcustomattr.c \
-       addressadd.c \
        addressbook.c \
        addressbook_foldersel.c \
-       addrgather.c \
-       addrharvest.c \
        addrindex.c \
-       addritem.c \
        addrquery.c \
        addrselect.c \
        addrduplicates.c \
-       alertpanel.c \
-       autofaces.c \
        browseldap.c \
-       codeconv.c \
-       compose.c \
-       crash.c \
-       customheader.c \
-       displayheader.c \
        editaddress.c \
        editaddress_other_attributes_ldap.c \
        editbook.c \
@@ -62,21 +53,103 @@ claws_mail_SOURCES = \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
-       edittags.c \
        editvcard.c \
-       enriched.c \
        exphtmldlg.c \
        expldifdlg.c \
-       export.c \
        exporthtml.c \
        exportldif.c \
+       importldif.c \
+       importmutt.c \
+       importpine.c \
+       jpilot.c \
+       ldapctrl.c \
+       ldaplocate.c \
+       ldapquery.c \
+       ldapserver.c \
+       ldapupdate.c \
+       ldaputil.c \
+       ldif.c \
+       mutt.c \
+       pine.c \
+       vcard.c
+
+if BUILD_ALTADDRBOOK
+abook_source = $(alt_abook_source)
+abook_extra = $(orig_abook_source)
+else
+abook_source = $(orig_abook_source)
+abook_extra = $(alt_abook_source)
+endif
+
+abook_headers = \
+       addressbook-dbus.h \
+       adbookbase.h \
+       addrbook.h \
+       addrclip.h \
+       addrcustomattr.h \
+       addressbook.h \
+       addressbook_foldersel.h \
+       addrindex.h \
+       addrquery.h \
+       addrselect.h \
+       addrduplicates.h \
+       browseldap.h \
+       editaddress.h \
+       editaddress_other_attributes_ldap.h \
+       editbook.h \
+       editgroup.h \
+       editjpilot.h \
+       editldap_basedn.h \
+       editldap.h \
+       editvcard.h \
+       exphtmldlg.h \
+       expldifdlg.h \
+       exporthtml.h \
+       exportldif.h \
+       file_checker.h \
+       importldif.h \
+       importmutt.h \
+       importpine.h \
+       jpilot.h \
+       ldapctrl.h \
+       ldaplocate.h \
+       ldapquery.h \
+       ldapserver.h \
+       ldapupdate.h \
+       ldaputil.h \
+       ldif.h \
+       mutt.h \
+       pine.h \
+       vcard.h
+
+claws_mail_SOURCES = \
+       account.c \
+       action.c \
+       addrcache.c \
+       addr_compl.c \
+       addressadd.c \
+       addrgather.c \
+       addrharvest.c \
+       addritem.c \
+       advsearch.c \
+       alertpanel.c \
+       autofaces.c \
+       avatars.c \
+       codeconv.c \
+       compose.c \
+       crash.c \
+       customheader.c \
+       displayheader.c \
+       edittags.c \
+       enriched.c \
+       export.c \
+        file_checker.c \
        filtering.c \
        folder.c \
        folder_item_prefs.c \
        foldersel.c \
        folderutils.c \
        folderview.c \
-       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
@@ -84,18 +157,7 @@ claws_mail_SOURCES = \
        imap.c \
        imap_gtk.c \
        import.c \
-       importldif.c \
-       importmutt.c \
-       importpine.c \
        inc.c \
-       jpilot.c \
-       ldapctrl.c \
-       ldaplocate.c \
-       ldapquery.c \
-       ldapserver.c \
-       ldapupdate.c \
-       ldaputil.c \
-       ldif.c \
        localfolder.c \
        main.c \
        mainwindow.c \
@@ -110,12 +172,13 @@ claws_mail_SOURCES = \
        mh_gtk.c \
        mimeview.c \
        msgcache.c \
-       mutt.c \
        news.c \
        news_gtk.c \
        noticeview.c \
        partial_download.c \
-       pine.c \
+       password.c \
+       password_gtk.c \
+       passwordstore.c \
        pop.c \
        prefs_account.c \
        prefs_actions.c \
@@ -133,6 +196,7 @@ claws_mail_SOURCES = \
        prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
+       prefs_migration.c \
        prefs_msg_colors.c \
        prefs_other.c \
        prefs_quote.c \
@@ -159,7 +223,6 @@ claws_mail_SOURCES = \
        remotefolder.c \
        send_message.c \
        setup.c \
-       simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
@@ -171,61 +234,39 @@ claws_mail_SOURCES = \
        undo.c \
        unmime.c \
        uri_opener.c \
-       vcard.c \
-       wizard.c
+       wizard.c \
+       $(abook_source)
 
 claws_mailincludedir = $(pkgincludedir)
 claws_mailinclude_HEADERS = \
        account.h \
        action.h \
-       adbookbase.h \
-       addrbook.h \
        addrcache.h \
-       addrclip.h \
        addr_compl.h \
        addrdefs.h \
-       addrcustomattr.h \
        addressadd.h \
-       addressbook.h \
-       addressbook_foldersel.h \
+       addritem.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
-       addrindex.h \
-       addritem.h \
-       addrquery.h \
-       addrselect.h \
-       addrduplicates.h \
+       advsearch.h \
        alertpanel.h \
        autofaces.h \
-       browseldap.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
        customheader.h \
        displayheader.h \
-       editaddress.h \
-       editaddress_other_attributes_ldap.h \
-       editbook.h \
-       editgroup.h \
-       editjpilot.h \
-       editldap_basedn.h \
-       editldap.h \
        edittags.h \
-       editvcard.h \
        enriched.h \
-       exphtmldlg.h \
-       expldifdlg.h \
        export.h \
-       exporthtml.h \
-       exportldif.h \
        filtering.h \
        folder.h \
        folder_item_prefs.h \
        foldersel.h \
        folderutils.h \
        folderview.h \
-       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
@@ -233,23 +274,13 @@ claws_mailinclude_HEADERS = \
        imap.h \
        imap_gtk.h \
        import.h \
-       importldif.h \
-       importmutt.h \
-       importpine.h \
        inc.h \
-       jpilot.h \
-       ldapctrl.h \
-       ldaplocate.h \
-       ldapquery.h \
-       ldapserver.h \
-       ldapupdate.h \
-       ldaputil.h \
-       ldif.h \
        localfolder.h \
        main.h \
        mainwindow.h \
        manual.h \
        matcher.h \
+       matchertypes.h \
        matcher_parser.h \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
@@ -260,12 +291,13 @@ claws_mailinclude_HEADERS = \
        mh_gtk.h \
        mimeview.h \
        msgcache.h \
-       mutt.h \
        news.h \
        news_gtk.h \
        noticeview.h \
        partial_download.h \
-       pine.h \
+       password.h \
+       password_gtk.h \
+       passwordstore.h \
        pop.h \
        prefs_account.h \
        prefs_actions.h \
@@ -283,6 +315,7 @@ claws_mailinclude_HEADERS = \
        prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
+       prefs_migration.h \
        prefs_msg_colors.h \
        prefs_other.h \
        prefs_quote.h \
@@ -302,6 +335,7 @@ claws_mailinclude_HEADERS = \
        procheader.h \
        procmime.h \
        procmsg.h \
+       proctypes.h \
        quote_fmt.h \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
@@ -320,12 +354,22 @@ claws_mailinclude_HEADERS = \
        undo.h \
        unmime.h \
        uri_opener.h \
-       vcard.h \
-       wizard.h
+       viewtypes.h \
+       wizard.h \
+       $(abook_headers)
 
 BUILT_SOURCES = \
        matcher_parser_parse.h \
-       quote_fmt_parse.h
+       quote_fmt_parse.h \
+       client-bindings.h
+
+client-bindings.h: claws-contacts.xml
+if BUILD_ALTADDRBOOK
+       dbus-binding-tool --prefix=abook --mode=glib-client --output=$@ claws-contacts.xml
+
+CLEANFILES = \
+            client-bindings.h
+endif
 
 EXTRA_DIST = \
        w32-logo.ico w32-resource.rc \
@@ -343,6 +387,8 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_icon_64.xpm \
+       pixmaps/claws-mail_compose_logo.xpm \
        pixmaps/claws-mail_logo.xpm \
        pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
@@ -355,9 +401,14 @@ EXTRA_DIST = \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
        pixmaps/dir_close_hrm.xpm \
-       pixmaps/dir_noselect.xpm \
        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
+       pixmaps/dir_noselect_close.xpm \
+       pixmaps/dir_noselect_close_mark.xpm \
+       pixmaps/dir_noselect_open.xpm \
+       pixmaps/dir_subs_close_mark.xpm \
+       pixmaps/dir_subs_close.xpm \
+       pixmaps/dir_subs_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
@@ -380,6 +431,7 @@ EXTRA_DIST = \
        pixmaps/insert_file.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
+       pixmaps/key_gpg_signed.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
        pixmaps/linewrapcurrent.xpm \
@@ -488,23 +540,20 @@ EXTRA_DIST = \
        pixmaps/tray_unreadmail.xpm \
        pixmaps/tray_unreadmarkedmail.offline.xpm \
        pixmaps/tray_unreadmarkedmail.xpm \
-       pixmaps/empty.xpm
+       pixmaps/empty.xpm \
+       pixmaps/replied_and_forwarded.xpm \
+       claws-contacts.xml \
+       $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
-if PLATFORM_WIN32
-arch_ldflags := -export-all-symbols
-else
-arch_ldflags :=
-endif
-
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+       $(claws_mail_res_ldflag)
 
 claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
@@ -513,24 +562,20 @@ claws_mail_DEPENDENCIES = $(claws_mail_deps) \
 claws_mail_LDADD = \
        $(etpan_library) \
        gtk/libclawsgtk.la \
-       $(ASPELL_LIBS) \
+       $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
-       $(OPENSSL_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
-       $(GNOMEPRINT_LIBS) \
        $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
-       $(DBUS_LIBS)
+       $(DBUS_LIBS) \
+       $(CONTACTS_LIBS)
 
 pixmapdir=$(datadir)/icons/hicolor/48x48/apps
 
@@ -539,21 +584,20 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
-       $(ASPELL_CFLAGS) \
+       $(IFLAGS) \
+       $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
+       $(GNUTLS_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(GNOMEPRINT_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(DBUS_CFLAGS) \
-  $(NETWORKMANAGER_SUPPORT_CFLAGS)
+       $(NETWORKMANAGER_SUPPORT_CFLAGS) \
+       $(VALGRIND_CFLAGS) \
+       $(CONTACTS_CFLAGS)
 
 #no-unused-function is there because of bison stuff
 #no-deprecated-declarations because of gpgme_data_rewind, which we have