0.8.9claws11
[claws.git] / src / Makefile.am
index c9f8e4a97d01ac2b5c7ef872c6f363b5b554eb7b..99c592065713822afdbe48edd4a68a5027fea719 100644 (file)
@@ -1,11 +1,8 @@
-SUBDIRS = common gtk
+SUBDIRS = common gtk plugins
 
 bin_PROGRAMS = sylpheed
 
 sylpheed_SOURCES = \
-       intl.h \
-       defs.h \
-       version.h \
        main.c main.h \
        mainwindow.c mainwindow.h \
        folderview.c folderview.h \
@@ -22,11 +19,8 @@ sylpheed_SOURCES = \
        procmsg.c procmsg.h \
        procheader.c procheader.h \
        compose.c compose.h \
-       gtkshruler.c gtkshruler.h \
-       gtkstext.c gtkstext.h \
-       menu.c menu.h \
        stock_pixmap.c stock_pixmap.h \
-       prefs.c prefs.h \
+       prefs_gtk.c prefs_gtk.h \
        prefs_common.c prefs_common.h \
        prefs_account.c prefs_account.h \
        prefs_folder_item.c prefs_folder_item.h \
@@ -76,7 +70,6 @@ sylpheed_SOURCES = \
        statusbar.c statusbar.h \
        logwindow.c logwindow.h \
        sourcewindow.c sourcewindow.h \
-       manage_window.c manage_window.h \
        undo.c undo.h \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
@@ -84,7 +77,6 @@ sylpheed_SOURCES = \
        grouplistdialog.c grouplistdialog.h \
        about.c about.h \
        setup.c setup.h \
-       gtkutils.c gtkutils.h \
        codeconv.c codeconv.h \
        unmime.c unmime.h \
        ssl_manager.c ssl_manager.h \
@@ -110,7 +102,6 @@ sylpheed_SOURCES = \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
-       stringtable.c stringtable.h \
        scoring.c scoring.h \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
@@ -141,7 +132,6 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        quote_fmt_parse.h \
-       version.h.in \
        pixmaps/address_book.xpm \
        pixmaps/address.xpm \
        pixmaps/book.xpm \
@@ -230,13 +220,14 @@ sylpheed_LDADD = \
        $(GDK_PIXBUF_LIBS) \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
-       $(OPENSSL_LIBS)
+       $(OPENSSL_LIBS) \
+       $(LIBICONV)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
-       -DTARGET_ALIAS=\""$(target_alias)"\" \
+       -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d