0.9.7claws10
[claws.git] / src / Makefile.am
index b487f2276e8408b6fd9c3e6465e350e01cbe86cd..934e67ed9611aa26fcf343d5803f066a3f8c9c19 100644 (file)
@@ -15,8 +15,10 @@ sylpheed_SOURCES = \
        addrharvest.c \
        addrindex.c \
        addritem.c \
+       addrquery.c \
        addrselect.c \
        alertpanel.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -52,11 +54,11 @@ sylpheed_SOURCES = \
        inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       logwindow.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -64,7 +66,6 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mbox_folder.c \
        message_search.c \
        messageview.c \
        mh.c \
@@ -74,6 +75,7 @@ sylpheed_SOURCES = \
        news.c \
        noticeview.c \
        passphrase.c \
+       pgpmime.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -81,9 +83,10 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
-       prefs_filtering.c \
        prefs_filtering_action.c \
+       prefs_filtering.c \
        prefs_folder_item.c \
+       prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
        prefs_scoring.c \
@@ -91,19 +94,20 @@ sylpheed_SOURCES = \
        prefs_summary_column.c \
        prefs_template.c \
        prefs_toolbar.c \
+       privacy.c \
        procheader.c \
        procmime.c \
        procmsg.c \
-       progressdialog.c \
+       quote_fmt.c \
        quote_fmt_lex.l \
-       quote_fmt_parse.y quote_fmt.c \
+       quote_fmt_parse.y \
        recv.c \
        rfc2015.c \
        scoring.c \
        select-keys.c \
        send_message.c \
        setup.c \
-       sigstatus.c \
+       sgpgme.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -116,6 +120,8 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       localfolder.c \
+       remotefolder.c \
        vcard.c
 
 sylpheedincludedir = $(pkgincludedir)
@@ -127,6 +133,7 @@ sylpheedinclude_HEADERS = \
        addrcache.h \
        addrclip.h \
        addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -137,6 +144,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -151,8 +159,10 @@ sylpheedinclude_HEADERS = \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
+       expldifdlg.h \
        export.h \
        exporthtml.h \
+       exportldif.h \
        filtering.h \
        folder.h \
        folder_item_prefs.h \
@@ -170,20 +180,18 @@ sylpheedinclude_HEADERS = \
        inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       logwindow.h \
        main.h \
        mainwindow.h \
        manual.h \
        matcher.h \
-       matcher_parser_lex.h \
-       matcher_parser_parse.y \
        matcher_parser.h \
+       matcher_parser_lex.h \
        matcher_parser_parse.h \
-       mbox_folder.h \
        mbox.h \
        message_search.h \
        messageview.h \
@@ -194,6 +202,7 @@ sylpheedinclude_HEADERS = \
        news.h \
        noticeview.h \
        passphrase.h \
+       pgpmime.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -201,9 +210,10 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
-       prefs_filtering.h \
        prefs_filtering_action.h \
+       prefs_filtering.h \
        prefs_folder_item.h \
+       prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
        prefs_scoring.h \
@@ -211,19 +221,20 @@ sylpheedinclude_HEADERS = \
        prefs_summary_column.h \
        prefs_template.h \
        prefs_toolbar.h \
+       privacy.h \
        procheader.h \
        procmime.h \
        procmsg.h \
-       progressdialog.h \
-       quote_fmt_lex.l quote_fmt_lex.h \
-       quote_fmt_parse.y quote_fmt.h \
+       quote_fmt.h \
+       quote_fmt_lex.h \
+       quote_fmt_parse.h \
        recv.h \
        rfc2015.h \
        scoring.h \
        select-keys.h \
        send_message.h \
        setup.h \
-       sigstatus.h \
+       sgpgme.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -235,24 +246,23 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       localfolder.h \
+       remotefolder.h \
        vcard.h
 
 BUILT_SOURCES = \
-       quote_fmt_lex.c \
-       quote_fmt_parse.c \
-       quote_fmt_parse.h \
-       matcher_parser_lex.c \
-       matcher_parser_parse.c \
-       matcher_parser_parse.h
+       matcher_parser_parse.h \
+       quote_fmt_parse.h
 
 EXTRA_DIST = \
-       quote_fmt_parse.h \
        pixmaps/address_book.xpm \
+       pixmaps/address_search.xpm \
        pixmaps/address.xpm \
        pixmaps/book.xpm \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
        pixmaps/close.xpm \
@@ -292,16 +302,10 @@ EXTRA_DIST = \
        pixmaps/mail_send.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
-       pixmaps/messageview_text.xpm \
-       pixmaps/mime_application_octet_stream.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -315,6 +319,12 @@ EXTRA_DIST = \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/regular.xpm \
@@ -333,8 +343,7 @@ EXTRA_DIST = \
 INCLUDES = \
        -Icommon \
        -Igtk \
-       -I$(top_srcdir)/intl \
-       -I$(includedir)
+       -I$(top_srcdir)/intl
 
 sylpheed_LDFLAGS = \
        -export-dynamic
@@ -347,6 +356,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
        $(LIBICONV)
 
 AM_CPPFLAGS = \