2006-07-31 [wwp] 2.4.0cvs3
[claws.git] / src / Makefile.am
index bef239d27ba8615ec75cdc925337d645c2b88254..867632a0041bd1dd8fc4503fae06c5cd5901c1b4 100644 (file)
@@ -1,8 +1,17 @@
-SUBDIRS = common gtk plugins
 
-bin_PROGRAMS = sylpheed
+if SYLPHEED_LIBETPAN
+etpan_dir = etpan
+etpan_library = etpan/libsylpheedetpan.la
+else
+etpan_dir =
+etpan_library = 
+endif
 
-sylpheed_SOURCES = \
+SUBDIRS = common gtk $(etpan_dir) . plugins
+
+bin_PROGRAMS = sylpheed-claws
+
+sylpheed_claws_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -11,6 +20,7 @@ sylpheed_SOURCES = \
        addr_compl.c \
        addressadd.c \
        addressbook.c \
+       addressbook_foldersel.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
@@ -43,9 +53,11 @@ sylpheed_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
+       image_viewer.c \
        imap.c \
        imap_gtk.c \
        import.c \
@@ -84,6 +96,7 @@ sylpheed_SOURCES = \
        prefs_account.c \
        prefs_actions.c \
        prefs_common.c \
+       prefs_compose_writing.c \
        prefs_customheader.c \
        prefs_display_header.c \
        prefs_ext_prog.c \
@@ -92,10 +105,18 @@ sylpheed_SOURCES = \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
+       prefs_image_viewer.c \
        prefs_matcher.c \
+       prefs_message.c \
        prefs_msg_colors.c \
+       prefs_other.c \
+       prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
+       prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
@@ -125,8 +146,8 @@ sylpheed_SOURCES = \
        vcard.c \
        wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+sylpheed_clawsincludedir = $(pkgincludedir)
+sylpheed_clawsinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -137,6 +158,7 @@ sylpheedinclude_HEADERS = \
        addrdefs.h \
        addressadd.h \
        addressbook.h \
+       addressbook_foldersel.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
@@ -170,9 +192,11 @@ sylpheedinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
+       image_viewer.h \
        imap.h \
        imap_gtk.h \
        import.h \
@@ -212,6 +236,7 @@ sylpheedinclude_HEADERS = \
        prefs_account.h \
        prefs_actions.h \
        prefs_common.h \
+       prefs_compose_writing.h \
        prefs_customheader.h \
        prefs_display_header.h \
        prefs_ext_prog.h \
@@ -220,10 +245,18 @@ sylpheedinclude_HEADERS = \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
+       prefs_image_viewer.h \
        prefs_matcher.h \
+       prefs_message.h \
        prefs_msg_colors.h \
+       prefs_other.h \
+       prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
+       prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
@@ -267,12 +300,14 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clip_gpg_signed.xpm \
        pixmaps/close.xpm \
        pixmaps/complete.xpm \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
-       pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_noselect.xpm \
+        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
@@ -282,6 +317,7 @@ EXTRA_DIST = \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
+       pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
        pixmaps/inbox_hrm.xpm \
        pixmaps/inbox.xpm \
@@ -338,24 +374,48 @@ EXTRA_DIST = \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
-       pixmaps/sylpheed_icon.xpm \
-       pixmaps/sylpheed_logo.xpm \
-       pixmaps/sylpheed.xpm \
+       pixmaps/spam.xpm \
+       pixmaps/spam_btn.xpm \
+       pixmaps/sylpheed-claws_icon.xpm \
+       pixmaps/sylpheed-claws_logo.xpm \
+       pixmaps/sylpheed-claws.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
        pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
-       -Icommon \
-       -Igtk
+       -I$(srcdir)/common \
+       -I$(srcdir)/gtk \
+       -I$(srcdir)/etpan
 
-sylpheed_LDFLAGS = \
-       -export-dynamic
+if PLATFORM_WIN32
+arch_ldflags := -export-all-symbols
+else
+arch_ldflags :=
+endif
 
-sylpheed_LDADD = \
+sylpheed_claws_LDFLAGS = \
+       $(arch_ldflags) -export-dynamic
+
+sylpheed_claws_LDADD = \
+       $(etpan_library) \
        gtk/libsylpheedgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
@@ -366,11 +426,13 @@ sylpheed_LDADD = \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
        $(LIBICONV) \
-       $(STARTUP_NOTIFICATION_LIBS)
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -380,6 +442,30 @@ AM_CPPFLAGS = \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(OPENSSL_CFLAGS) \
-       $(STARTUP_NOTIFICATION_CFLAGS)
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
 AM_YFLAGS = -d
+
+if CYGWIN
+sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
+       @rm -f sylpheed-claws$(EXEEXT)
+       @rm -f sylpheed-claws.def sylpheed-claws.base sylpheed-claws.exp libsylpheed-claws.a .libs/libsylpheed-claws.a
+       $(LINK) -shared $(sylpheed_clawsLDFLAGS) -Wl,--out-implib=libsylpheed-claws.a -Wl,--export-all-symbols,--exclude-symbols,main $(sylpheed_claws_OBJECTS) -Wl,--no-whole-archive $(sylpheed_claws_LDADD) $(LIBS)
+       dlltool --output-def sylpheed-claws.def --dllname sylpheed-claws$(EXEEXT) --export-all-symbols --exclude-symbols main $(sylpheed_claws_OBJECTS) gtk/.libs/libsylpheedgtk.a
+       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,--base-file,sylpheed-claws.base $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+       sleep 5
+       dlltool --base-file sylpheed-claws.base --input-def sylpheed-claws.def --output-exp sylpheed-claws.exp
+       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,sylpheed-claws.exp $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+       @cp libsylpheed-claws.a .libs/libsylpheed-claws.a
+else
+#sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
+#      @rm -f sylpheed-claws$(EXEEXT)
+#      $(LINK) $(sylpheed_claws_LDFLAGS) $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+endif