2006-07-31 [wwp] 2.4.0cvs3
[claws.git] / src / Makefile.am
index 10f9b91907db3f981a644d14e3e86fc9ea7296e8..867632a0041bd1dd8fc4503fae06c5cd5901c1b4 100644 (file)
@@ -1,22 +1,17 @@
-SUBDIRS = common gtk plugins
-
-
-if PLATFORM_WIN32
-
-SYLPHEED_RES = sylpheed.res
-
-sylpheed.rc:
-       echo "SYLPHEED ICON sylpheed.ico" > sylpheed.rc
-
-sylpheed.res: sylpheed.rc
-       $(WINDRES) $< -O coff -o $@
 
+if SYLPHEED_LIBETPAN
+etpan_dir = etpan
+etpan_library = etpan/libsylpheedetpan.la
+else
+etpan_dir =
+etpan_library = 
 endif
 
+SUBDIRS = common gtk $(etpan_dir) . plugins
 
-bin_PROGRAMS = sylpheed
+bin_PROGRAMS = sylpheed-claws
 
-sylpheed_SOURCES = \
+sylpheed_claws_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -25,6 +20,7 @@ sylpheed_SOURCES = \
        addr_compl.c \
        addressadd.c \
        addressbook.c \
+       addressbook_foldersel.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
@@ -57,16 +53,18 @@ sylpheed_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
+       image_viewer.c \
        imap.c \
+       imap_gtk.c \
        import.c \
        importldif.c \
        importmutt.c \
        importpine.c \
        inc.c \
-       inputdialog.c \
        jpilot.c \
        ldapctrl.c \
        ldaplocate.c \
@@ -85,18 +83,20 @@ sylpheed_SOURCES = \
        message_search.c \
        messageview.c \
        mh.c \
+       mh_gtk.c \
        mimeview.c \
        msgcache.c \
        mutt.c \
        news.c \
+       news_gtk.c \
        noticeview.c \
-       passphrase.c \
-       pgpmime.c \
+       partial_download.c \
        pine.c \
        pop.c \
        prefs_account.c \
        prefs_actions.c \
        prefs_common.c \
+       prefs_compose_writing.c \
        prefs_customheader.c \
        prefs_display_header.c \
        prefs_ext_prog.c \
@@ -105,12 +105,22 @@ sylpheed_SOURCES = \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
+       prefs_image_viewer.c \
        prefs_matcher.c \
+       prefs_message.c \
+       prefs_msg_colors.c \
+       prefs_other.c \
+       prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
+       prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
+       prefs_wrapping.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -120,11 +130,8 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y \
        recv.c \
        remotefolder.c \
-       rfc2015.c \
-       select-keys.c \
        send_message.c \
        setup.c \
-       sgpgme.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -136,10 +143,11 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
-       vcard.c
+       vcard.c \
+       wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+sylpheed_clawsincludedir = $(pkgincludedir)
+sylpheed_clawsinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -150,6 +158,7 @@ sylpheedinclude_HEADERS = \
        addrdefs.h \
        addressadd.h \
        addressbook.h \
+       addressbook_foldersel.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
@@ -183,16 +192,18 @@ sylpheedinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
+       image_viewer.h \
        imap.h \
+       imap_gtk.h \
        import.h \
        importldif.h \
        importmutt.h \
        importpine.h \
        inc.h \
-       inputdialog.h \
        jpilot.h \
        ldapctrl.h \
        ldaplocate.h \
@@ -212,18 +223,20 @@ sylpheedinclude_HEADERS = \
        message_search.h \
        messageview.h \
        mh.h \
+       mh_gtk.h \
        mimeview.h \
        msgcache.h \
        mutt.h \
        news.h \
+       news_gtk.h \
        noticeview.h \
-       passphrase.h \
-       pgpmime.h \
+       partial_download.h \
        pine.h \
        pop.h \
        prefs_account.h \
        prefs_actions.h \
        prefs_common.h \
+       prefs_compose_writing.h \
        prefs_customheader.h \
        prefs_display_header.h \
        prefs_ext_prog.h \
@@ -232,12 +245,22 @@ sylpheedinclude_HEADERS = \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
+       prefs_image_viewer.h \
        prefs_matcher.h \
+       prefs_message.h \
+       prefs_msg_colors.h \
+       prefs_other.h \
+       prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
+       prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
+       prefs_wrapping.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -247,11 +270,8 @@ sylpheedinclude_HEADERS = \
        quote_fmt_parse.h \
        recv.h \
        remotefolder.h \
-       rfc2015.h \
-       select-keys.h \
        send_message.h \
        setup.h \
-       sgpgme.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -262,14 +282,14 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
-       vcard.h
+       vcard.h \
+       wizard.h
 
 BUILT_SOURCES = \
        matcher_parser_parse.h \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       sylpheed.ico \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
@@ -280,22 +300,24 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clip_gpg_signed.xpm \
        pixmaps/close.xpm \
        pixmaps/complete.xpm \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
-       pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_noselect.xpm \
+        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
-       pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
+       pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
        pixmaps/inbox_hrm.xpm \
        pixmaps/inbox.xpm \
@@ -304,6 +326,7 @@ EXTRA_DIST = \
        pixmaps/key.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
+       pixmaps/linewrapcurrent.xpm \
        pixmaps/locked.xpm \
        pixmaps/mail_attach.xpm \
        pixmaps/mail_compose.xpm \
@@ -342,28 +365,57 @@ EXTRA_DIST = \
        pixmaps/privacy_signed.xpm \
        pixmaps/privacy_unknown.xpm \
        pixmaps/privacy_warn.xpm \
+       pixmaps/privacy_emblem_encrypted.xpm \
+       pixmaps/privacy_emblem_failed.xpm \
+       pixmaps/privacy_emblem_passed.xpm \
+       pixmaps/privacy_emblem_signed.xpm \
+       pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
-       pixmaps/regular.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
-       pixmaps/sylpheed_logo.xpm \
-       pixmaps/sylpheed.xpm \
+       pixmaps/spam.xpm \
+       pixmaps/spam_btn.xpm \
+       pixmaps/sylpheed-claws_icon.xpm \
+       pixmaps/sylpheed-claws_logo.xpm \
+       pixmaps/sylpheed-claws.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
+       pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
-       -Icommon \
-       -Igtk \
-       -I$(top_srcdir)/intl
+       -I$(srcdir)/common \
+       -I$(srcdir)/gtk \
+       -I$(srcdir)/etpan
+
+if PLATFORM_WIN32
+arch_ldflags := -export-all-symbols
+else
+arch_ldflags :=
+endif
 
-sylpheed_LDFLAGS = \
-       -export-dynamic
+sylpheed_claws_LDFLAGS = \
+       $(arch_ldflags) -export-dynamic
 
-sylpheed_LDADD = \
+sylpheed_claws_LDADD = \
+       $(etpan_library) \
        gtk/libsylpheedgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
@@ -373,11 +425,14 @@ sylpheed_LDADD = \
        $(OPENSSL_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
+       $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
        $(LIBICONV) \
-       $(SYLPHEED_RES)
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -386,6 +441,31 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
 AM_YFLAGS = -d
+
+if CYGWIN
+sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
+       @rm -f sylpheed-claws$(EXEEXT)
+       @rm -f sylpheed-claws.def sylpheed-claws.base sylpheed-claws.exp libsylpheed-claws.a .libs/libsylpheed-claws.a
+       $(LINK) -shared $(sylpheed_clawsLDFLAGS) -Wl,--out-implib=libsylpheed-claws.a -Wl,--export-all-symbols,--exclude-symbols,main $(sylpheed_claws_OBJECTS) -Wl,--no-whole-archive $(sylpheed_claws_LDADD) $(LIBS)
+       dlltool --output-def sylpheed-claws.def --dllname sylpheed-claws$(EXEEXT) --export-all-symbols --exclude-symbols main $(sylpheed_claws_OBJECTS) gtk/.libs/libsylpheedgtk.a
+       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,--base-file,sylpheed-claws.base $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+       sleep 5
+       dlltool --base-file sylpheed-claws.base --input-def sylpheed-claws.def --output-exp sylpheed-claws.exp
+       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,sylpheed-claws.exp $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+       @cp libsylpheed-claws.a .libs/libsylpheed-claws.a
+else
+#sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
+#      @rm -f sylpheed-claws$(EXEEXT)
+#      $(LINK) $(sylpheed_claws_LDFLAGS) $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+endif