0.9.6claws97
[claws.git] / src / Makefile.am
index 25c6e6bdf79b163149457a60243b4cdfba30851d..84791551ddfa1443f1929959e7daee4b94aaa69e 100644 (file)
@@ -15,8 +15,10 @@ sylpheed_SOURCES = \
        addrharvest.c \
        addrindex.c \
        addritem.c \
+       addrquery.c \
        addrselect.c \
        alertpanel.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -52,11 +54,11 @@ sylpheed_SOURCES = \
        inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       logwindow.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -64,7 +66,6 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mbox_folder.c \
        message_search.c \
        messageview.c \
        mh.c \
@@ -74,6 +75,7 @@ sylpheed_SOURCES = \
        news.c \
        noticeview.c \
        passphrase.c \
+       pgpmime.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -81,28 +83,31 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
-       prefs_filtering.c \
        prefs_filtering_action.c \
+       prefs_filtering.c \
        prefs_folder_item.c \
+       prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
        prefs_scoring.c \
+       prefs_spelling.c \
        prefs_summary_column.c \
        prefs_template.c \
        prefs_toolbar.c \
+       privacy.c \
        procheader.c \
        procmime.c \
        procmsg.c \
-       progressdialog.c \
+       quote_fmt.c \
        quote_fmt_lex.l \
-       quote_fmt_parse.y quote_fmt.c \
+       quote_fmt_parse.y \
        recv.c \
        rfc2015.c \
        scoring.c \
        select-keys.c \
        send_message.c \
        setup.c \
-       sigstatus.c \
+       sgpgme.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -126,6 +131,7 @@ sylpheedinclude_HEADERS = \
        addrcache.h \
        addrclip.h \
        addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -136,6 +142,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -150,8 +157,10 @@ sylpheedinclude_HEADERS = \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
+       expldifdlg.h \
        export.h \
        exporthtml.h \
+       exportldif.h \
        filtering.h \
        folder.h \
        folder_item_prefs.h \
@@ -169,20 +178,18 @@ sylpheedinclude_HEADERS = \
        inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       logwindow.h \
        main.h \
        mainwindow.h \
        manual.h \
        matcher.h \
-       matcher_parser_lex.h \
-       matcher_parser_parse.y \
        matcher_parser.h \
+       matcher_parser_lex.h \
        matcher_parser_parse.h \
-       mbox_folder.h \
        mbox.h \
        message_search.h \
        messageview.h \
@@ -193,6 +200,7 @@ sylpheedinclude_HEADERS = \
        news.h \
        noticeview.h \
        passphrase.h \
+       pgpmime.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -200,28 +208,31 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
-       prefs_filtering.h \
        prefs_filtering_action.h \
+       prefs_filtering.h \
        prefs_folder_item.h \
+       prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
        prefs_scoring.h \
+       prefs_spelling.h \
        prefs_summary_column.h \
        prefs_template.h \
        prefs_toolbar.h \
+       privacy.h \
        procheader.h \
        procmime.h \
        procmsg.h \
-       progressdialog.h \
-       quote_fmt_lex.l quote_fmt_lex.h \
-       quote_fmt_parse.y quote_fmt.h \
+       quote_fmt.h \
+       quote_fmt_lex.h \
+       quote_fmt_parse.h \
        recv.h \
        rfc2015.h \
        scoring.h \
        select-keys.h \
        send_message.h \
        setup.h \
-       sigstatus.h \
+       sgpgme.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -236,16 +247,12 @@ sylpheedinclude_HEADERS = \
        vcard.h
 
 BUILT_SOURCES = \
-       quote_fmt_lex.c \
-       quote_fmt_parse.c \
-       quote_fmt_parse.h \
-       matcher_parser_lex.c \
-       matcher_parser_parse.c \
-       matcher_parser_parse.h
+       matcher_parser_parse.h \
+       quote_fmt_parse.h
 
 EXTRA_DIST = \
-       quote_fmt_parse.h \
        pixmaps/address_book.xpm \
+       pixmaps/address_search.xpm \
        pixmaps/address.xpm \
        pixmaps/book.xpm \
        pixmaps/category.xpm \
@@ -290,15 +297,8 @@ EXTRA_DIST = \
        pixmaps/mail_send.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
-       pixmaps/messageview_text.xpm \
-       pixmaps/mime_application_octet_stream.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
@@ -313,6 +313,12 @@ EXTRA_DIST = \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/regular.xpm \
@@ -331,8 +337,7 @@ EXTRA_DIST = \
 INCLUDES = \
        -Icommon \
        -Igtk \
-       -I$(top_srcdir)/intl \
-       -I$(includedir)
+       -I$(top_srcdir)/intl
 
 sylpheed_LDFLAGS = \
        -export-dynamic
@@ -345,6 +350,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
        $(LIBICONV)
 
 AM_CPPFLAGS = \