New address book.
[claws.git] / src / Makefile.am
index add50ca4e259c32dff06fb6a8f66ea3c31770a4b..823f87fecde90372356af3a752b1fed2b4d972d1 100644 (file)
@@ -13,6 +13,7 @@ sylpheed_SOURCES = \
        imageview.c imageview.h \
        mimeview.c mimeview.h \
        summary_search.c summary_search.h \
+       colorlabel.c colorlabel.h \
        folder.c folder.h \
        procmsg.c procmsg.h \
        procheader.c procheader.h \
@@ -25,8 +26,13 @@ sylpheed_SOURCES = \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_display_header.c prefs_display_header.h \
+       prefs_customheader.c prefs_customheader.h \
        account.c account.h \
+       displayheader.c displayheader.h \
+       customheader.c customheader.h \
        addressbook.c addressbook.h \
+       addr_compl.c addr_compl.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -37,6 +43,7 @@ sylpheed_SOURCES = \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
        progressdialog.c progressdialog.h \
+       grouplistdialog.c grouplistdialog.h \
        about.c about.h \
        setup.c setup.h \
        utils.c utils.h \
@@ -48,6 +55,7 @@ sylpheed_SOURCES = \
        md5.c md5.h \
        rfc822.c rfc822.h \
        socket.c socket.h \
+       ssl.c ssl.h \
        automaton.c automaton.h \
        session.c session.h \
        smtp.c smtp.h \
@@ -72,18 +80,43 @@ sylpheed_SOURCES = \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
-       addr_compl.c addr_compl.h \
+       stringtable.c stringtable.h \
        gtkstext.c gtkstext.h \
-       grouplist_dialog.c grouplist_dialog.h \
-       customheader.c customheader.h \
-       prefs_headers.c prefs_headers.h \
-       headers_display.c headers_display.h \
-       prefs_display_headers.c prefs_display_headers.h \
        scoring.c scoring.h \
        prefs_folder_item.c prefs_folder_item.h \
-       matcher.c matcher.h
+       matcher.c matcher.h \
+       prefs_matcher.c prefs_matcher.h \
+       prefs_scoring.c prefs_scoring.h \
+       filtering.c filtering.h \
+       prefs_filtering.c prefs_filtering.h \
+       mbox_folder.c mbox_folder.h \
+       quote_fmt_lex.l quote_fmt_lex.h \
+       quote_fmt_parse.y quote_fmt.h \
+       addressitem.h \
+       addritem.c addritem.h \
+       addrcache.c addrcache.h \
+       addrbook.c addrbook.h \
+       addrindex.c addrindex.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editbook.c editbook.h \
+       editgroup.c editgroup.h \
+       editaddress.c editaddress.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h \
+       addressadd.c addressadd.h \
+       gtkspell.c gtkspell.h gtkxtext.h \
+       template.c template.h \
+       prefs_templates.c prefs_templates.h \
+       template_select.c template_select.h
+
 
 EXTRA_DIST = \
+       quote_fmt_parse.h \
        pixmaps/clip.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir-close.xpm \
@@ -108,9 +141,12 @@ EXTRA_DIST = \
        pixmaps/stock_mail_receive.xpm \
        pixmaps/stock_mail_receive_all.xpm \
        pixmaps/stock_mail_send.xpm \
+       pixmaps/stock_mail_send_queue.xpm \
        pixmaps/stock_mail_compose.xpm \
+       pixmaps/stock_news_compose.xpm \
        pixmaps/stock_mail_reply.xpm \
        pixmaps/stock_mail_reply_to_all.xpm \
+       pixmaps/stock_mail_reply_to_author.xpm \
        pixmaps/stock_mail_forward.xpm \
        pixmaps/stock_preferences.xpm \
        pixmaps/stock_properties.xpm \
@@ -122,7 +158,15 @@ EXTRA_DIST = \
        pixmaps/stock_down_arrow.xpm \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm
+       pixmaps/sylpheed-logo.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/book.xpm \
+       pixmaps/address.xpm \
+       pixmaps/vcard.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/category.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/ignorethread.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -144,4 +188,14 @@ sylpheed_LDADD = \
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\"
+       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"
+
+YFLAGS = -d
+
+
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h
+