2007-06-12 [colin] 2.9.2cvs57
[claws.git] / src / Makefile.am
index 735beaf5e9775159e2056cbc2d6d1f2818c027c3..7693fc2aa63ccf08255bf30592476eacdce7e1c6 100644 (file)
@@ -73,6 +73,7 @@ claws_mail_SOURCES = \
        ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
+       ldapupdate.c \
        ldaputil.c \
        ldif.c \
        localfolder.c \
@@ -109,6 +110,7 @@ claws_mail_SOURCES = \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_image_viewer.c \
+       prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
        prefs_msg_colors.c \
@@ -119,6 +121,7 @@ claws_mail_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
@@ -146,6 +149,7 @@ claws_mail_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       uri_opener.c \
        vcard.c \
        wizard.c
 
@@ -212,6 +216,7 @@ claws_mailinclude_HEADERS = \
        ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
+       ldapupdate.h \
        ldaputil.h \
        ldif.h \
        localfolder.h \
@@ -249,6 +254,7 @@ claws_mailinclude_HEADERS = \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_image_viewer.h \
+       prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
        prefs_msg_colors.h \
@@ -259,6 +265,7 @@ claws_mailinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
@@ -285,6 +292,7 @@ claws_mailinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       uri_opener.h \
        vcard.h \
        wizard.h
 
@@ -293,7 +301,6 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       pixmaps/active.xpm \
        pixmaps/addr_one.xpm \
        pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
@@ -312,12 +319,16 @@ EXTRA_DIST = \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
+       pixmaps/dir_close_hrm.xpm \
        pixmaps/dir_noselect.xpm \
-        pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
+       pixmaps/drafts_close.xpm \
+       pixmaps/drafts_open.xpm \
+       pixmaps/edit_extern.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
@@ -325,9 +336,10 @@ EXTRA_DIST = \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inactive.xpm \
-       pixmaps/inbox_hrm.xpm \
-       pixmaps/inbox.xpm \
+       pixmaps/inbox_open_hrm.xpm \
+       pixmaps/inbox_open.xpm \
+       pixmaps/inbox_close_hrm.xpm \
+       pixmaps/inbox_close.xpm \
        pixmaps/interface.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
@@ -345,12 +357,17 @@ EXTRA_DIST = \
        pixmaps/mail_reply.xpm \
        pixmaps/mail_send_queue.xpm \
        pixmaps/mail_send.xpm \
+       pixmaps/mail_sign.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_message.xpm \
+       pixmaps/mime_pdf.xpm \
+       pixmaps/mime_ps.xpm \
+       pixmaps/mime_calendar.xpm \
+       pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -362,10 +379,18 @@ EXTRA_DIST = \
        pixmaps/notice_warn.xpm \
        pixmaps/offline.xpm \
        pixmaps/online.xpm \
-       pixmaps/outbox_hrm.xpm \
-       pixmaps/outbox.xpm \
+       pixmaps/open_mail.xpm \
+       pixmaps/outbox_close.xpm \
+       pixmaps/outbox_close_hrm.xpm \
+       pixmaps/outbox_open.xpm \
+       pixmaps/outbox_open_hrm.xpm \
+       pixmaps/outbox_close_mark.xpm \
+       pixmaps/outbox_close_hrm_mark.xpm \
+       pixmaps/outbox_open_mark.xpm \
+       pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -378,9 +403,18 @@ EXTRA_DIST = \
        pixmaps/privacy_emblem_signed.xpm \
        pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
+       pixmaps/queue_close.xpm \
+       pixmaps/queue_close_hrm.xpm \
+       pixmaps/queue_close_hrm_mark.xpm \
+       pixmaps/queue_close_mark.xpm \
+       pixmaps/queue_open.xpm \
+       pixmaps/queue_open_hrm.xpm \
+       pixmaps/queue_open_hrm_mark.xpm \
+       pixmaps/queue_open_mark.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/selection.xpm \
        pixmaps/spam.xpm \
        pixmaps/spam_btn.xpm \
        pixmaps/claws-mail_icon.xpm \
@@ -394,14 +428,15 @@ EXTRA_DIST = \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
        pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_close_hrm_mark.xpm \
        pixmaps/dir_open_hrm_mark.xpm \
        pixmaps/dir_open_mark.xpm \
        pixmaps/drafts_close_mark.xpm \
        pixmaps/drafts_open_mark.xpm \
-       pixmaps/inbox_hrm_mark.xpm \
-       pixmaps/inbox_mark.xpm \
-       pixmaps/outbox_hrm_mark.xpm \
-       pixmaps/outbox_mark.xpm \
+       pixmaps/inbox_open_hrm_mark.xpm \
+       pixmaps/inbox_open_mark.xpm \
+       pixmaps/inbox_close_hrm_mark.xpm \
+       pixmaps/inbox_close_mark.xpm \
        pixmaps/trash_hrm_mark.xpm \
        pixmaps/trash_mark.xpm \
        pixmaps/moved.xpm \
@@ -439,7 +474,8 @@ claws_mail_LDADD = \
        $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
-       $(LIBETPAN_LIBS)
+       $(LIBETPAN_LIBS) \
+       $(MAEMO_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Claws-Mail\" \
@@ -448,6 +484,7 @@ AM_CPPFLAGS = \
        -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
@@ -455,6 +492,7 @@ AM_CPPFLAGS = \
        $(GNOMEPRINT_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
+       $(MAEMO_CFLAGS) \
        -Wno-unused-function
         
 #no-unused-function is there because of bison stuff