2004-12-02 [paul] 0.9.12cvs180
[claws.git] / src / Makefile.am
index 0092ff8f06654ada215e406b77436da69dff0028..7131ae4bdf540d6de0fad55046e63dd9f60bcf1d 100644 (file)
@@ -18,8 +18,7 @@ sylpheed_SOURCES = \
        addrquery.c \
        addrselect.c \
        alertpanel.c \
-       carray.c \
-       chash.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -42,24 +41,26 @@ sylpheed_SOURCES = \
        folder.c \
        folder_item_prefs.c \
        foldersel.c \
+       folderutils.c \
        folderview.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
        imap.c \
+       imap_gtk.c \
        import.c \
        importldif.c \
        importmutt.c \
        importpine.c \
        inc.c \
-       inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       maillock.c \
+       localfolder.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -67,20 +68,17 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mailmbox_folder.c \
-       mailmbox.c \
-       mailmbox_parse.c \
-       mailmbox_types.c \
        message_search.c \
        messageview.c \
        mh.c \
+       mh_gtk.c \
        mimeview.c \
        msgcache.c \
        mutt.c \
        news.c \
+       news_gtk.c \
        noticeview.c \
-       passphrase.c \
-       pgpmime.c \
+       partial_download.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -88,17 +86,20 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
+       prefs_ext_prog.c \
        prefs_filtering_action.c \
        prefs_filtering.c \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
-       prefs_scoring.c \
+       prefs_msg_colors.c \
        prefs_spelling.c \
        prefs_summary_column.c \
        prefs_template.c \
+       prefs_themes.c \
        prefs_toolbar.c \
+       prefs_wrapping.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -107,19 +108,14 @@ sylpheed_SOURCES = \
        quote_fmt_lex.l \
        quote_fmt_parse.y \
        recv.c \
-       rfc2015.c \
-       scoring.c \
-       select-keys.c \
+       remotefolder.c \
        send_message.c \
        setup.c \
-       sgpgme.c \
-       sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
        stock_pixmap.c \
-       string_match.c \
        summary_search.c \
        summaryview.c \
        textview.c \
@@ -137,6 +133,7 @@ sylpheedinclude_HEADERS = \
        addrcache.h \
        addrclip.h \
        addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -147,8 +144,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
-       carray.h \
-       chash.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -171,24 +167,26 @@ sylpheedinclude_HEADERS = \
        folder.h \
        folder_item_prefs.h \
        foldersel.h \
+       folderutils.h \
        folderview.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
        imap.h \
+       imap_gtk.h \
        import.h \
        importldif.h \
        importmutt.h \
        importpine.h \
        inc.h \
-       inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       maillock.h \
+       localfolder.h \
        main.h \
        mainwindow.h \
        manual.h \
@@ -197,20 +195,17 @@ sylpheedinclude_HEADERS = \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
        mbox.h \
-       mailmbox_folder.h \
-       mailmbox.h \
-       mailmbox_parse.h \
-       mailmbox_types.h \
        message_search.h \
        messageview.h \
        mh.h \
+       mh_gtk.h \
        mimeview.h \
        msgcache.h \
        mutt.h \
        news.h \
+       news_gtk.h \
        noticeview.h \
-       passphrase.h \
-       pgpmime.h \
+       partial_download.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -218,17 +213,20 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
+       prefs_ext_prog.h \
        prefs_filtering_action.h \
        prefs_filtering.h \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
-       prefs_scoring.h \
+       prefs_msg_colors.h \
        prefs_spelling.h \
        prefs_summary_column.h \
        prefs_template.h \
+       prefs_themes.h \
        prefs_toolbar.h \
+       prefs_wrapping.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -237,18 +235,13 @@ sylpheedinclude_HEADERS = \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
        recv.h \
-       rfc2015.h \
-       scoring.h \
-       select-keys.h \
+       remotefolder.h \
        send_message.h \
        setup.h \
-       sgpgme.h \
-       sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
        stock_pixmap.h \
-       string_match.h \
        summary_search.h \
        summaryview.h \
        textview.h \
@@ -269,6 +262,7 @@ EXTRA_DIST = \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
        pixmaps/close.xpm \
@@ -283,7 +277,6 @@ EXTRA_DIST = \
        pixmaps/drafts_open.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
-       pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
@@ -295,6 +288,7 @@ EXTRA_DIST = \
        pixmaps/key.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
+       pixmaps/linewrapcurrent.xpm \
        pixmaps/locked.xpm \
        pixmaps/mail_attach.xpm \
        pixmaps/mail_compose.xpm \
@@ -310,12 +304,8 @@ EXTRA_DIST = \
        pixmaps/mark.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -325,10 +315,23 @@ EXTRA_DIST = \
        pixmaps/notice_error.xpm \
        pixmaps/notice_note.xpm \
        pixmaps/notice_warn.xpm \
+       pixmaps/offline.xpm \
+       pixmaps/online.xpm \
        pixmaps/outbox_hrm.xpm \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
+       pixmaps/privacy_emblem_encrypted.xpm \
+       pixmaps/privacy_emblem_failed.xpm \
+       pixmaps/privacy_emblem_passed.xpm \
+       pixmaps/privacy_emblem_signed.xpm \
+       pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/regular.xpm \
@@ -339,10 +342,13 @@ EXTRA_DIST = \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
+       pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
-       pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/stock_dialog-error.xpm \
+       pixmaps/stock_dialog-info.xpm \
+       pixmaps/stock_dialog-question.xpm \
+       pixmaps/stock_dialog-warning.xpm 
 
 INCLUDES = \
        -Icommon \
@@ -360,7 +366,11 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
-       $(LIBICONV)
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
+       $(PTHREAD_LIBS) \
+       $(LIBICONV) \
+       $(STARTUP_NOTIFICATION_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -372,6 +382,7 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS)
 
 AM_YFLAGS = -d