2004-08-12 [colin] 0.9.12cvs57.5
[claws.git] / src / Makefile.am
index 0926c0d8571ba0835265d732ff2d1891086563b9..6b9c713ef6e06ff6b00cb181c74fe0afab42680d 100644 (file)
@@ -5,18 +5,20 @@ bin_PROGRAMS = sylpheed
 sylpheed_SOURCES = \
        account.c \
        action.c \
-       addr_compl.c \
        addrbook.c \
        addrcache.c \
        addrclip.c \
+       addr_compl.c \
        addressadd.c \
        addressbook.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
        addritem.c \
+       addrquery.c \
        addrselect.c \
        alertpanel.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -26,8 +28,8 @@ sylpheed_SOURCES = \
        editbook.c \
        editgroup.c \
        editjpilot.c \
-       editldap.c \
        editldap_basedn.c \
+       editldap.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -39,24 +41,26 @@ sylpheed_SOURCES = \
        folder.c \
        folder_item_prefs.c \
        foldersel.c \
+       folderutils.c \
        folderview.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
        imap.c \
+       imap_gtk.c \
        import.c \
        importldif.c \
        importmutt.c \
        importpine.c \
        inc.c \
-       inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       logwindow.c \
+       localfolder.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -64,14 +68,15 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mbox_folder.c \
        message_search.c \
        messageview.c \
        mh.c \
+       mh_gtk.c \
        mimeview.c \
        msgcache.c \
        mutt.c \
        news.c \
+       news_gtk.c \
        noticeview.c \
        passphrase.c \
        pine.c \
@@ -81,36 +86,38 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
-       prefs_filtering.c \
+       prefs_ext_prog.c \
        prefs_filtering_action.c \
+       prefs_filtering.c \
        prefs_folder_item.c \
+       prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
-       prefs_scoring.c \
+       prefs_msg_colors.c \
        prefs_spelling.c \
        prefs_summary_column.c \
        prefs_template.c \
+       prefs_themes.c \
        prefs_toolbar.c \
+       prefs_wrapping.c \
+       privacy.c \
        procheader.c \
        procmime.c \
        procmsg.c \
-       progressdialog.c \
        quote_fmt.c \
        quote_fmt_lex.l \
        quote_fmt_parse.y \
        recv.c \
+       remotefolder.c \
        rfc2015.c \
-       scoring.c \
        select-keys.c \
        send_message.c \
        setup.c \
-       sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
        stock_pixmap.c \
-       string_match.c \
        summary_search.c \
        summaryview.c \
        textview.c \
@@ -124,10 +131,11 @@ sylpheedinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
-       addr_compl.h \
        addrbook.h \
        addrcache.h \
        addrclip.h \
+       addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -138,6 +146,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -147,35 +156,39 @@ sylpheedinclude_HEADERS = \
        editbook.h \
        editgroup.h \
        editjpilot.h \
-       editldap.h \
        editldap_basedn.h \
+       editldap.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
+       expldifdlg.h \
        export.h \
        exporthtml.h \
+       exportldif.h \
        filtering.h \
        folder.h \
        folder_item_prefs.h \
        foldersel.h \
+       folderutils.h \
        folderview.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
        imap.h \
+       imap_gtk.h \
        import.h \
        importldif.h \
        importmutt.h \
        importpine.h \
        inc.h \
-       inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       logwindow.h \
+       localfolder.h \
        main.h \
        mainwindow.h \
        manual.h \
@@ -184,14 +197,15 @@ sylpheedinclude_HEADERS = \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
        mbox.h \
-       mbox_folder.h \
        message_search.h \
        messageview.h \
        mh.h \
+       mh_gtk.h \
        mimeview.h \
        msgcache.h \
        mutt.h \
        news.h \
+       news_gtk.h \
        noticeview.h \
        passphrase.h \
        pine.h \
@@ -201,35 +215,37 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
-       prefs_filtering.h \
+       prefs_ext_prog.h \
        prefs_filtering_action.h \
+       prefs_filtering.h \
        prefs_folder_item.h \
+       prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
-       prefs_scoring.h \
+       prefs_msg_colors.h \
        prefs_spelling.h \
        prefs_summary_column.h \
        prefs_template.h \
+       prefs_themes.h \
        prefs_toolbar.h \
+       prefs_wrapping.h \
+       privacy.h \
        procheader.h \
        procmime.h \
        procmsg.h \
-       progressdialog.h \
        quote_fmt.h \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
        recv.h \
+       remotefolder.h \
        rfc2015.h \
-       scoring.h \
        select-keys.h \
        send_message.h \
        setup.h \
-       sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
        stock_pixmap.h \
-       string_match.h \
        summary_search.h \
        summaryview.h \
        textview.h \
@@ -244,11 +260,13 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        pixmaps/address_book.xpm \
+       pixmaps/address_search.xpm \
        pixmaps/address.xpm \
        pixmaps/book.xpm \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
        pixmaps/close.xpm \
@@ -275,6 +293,7 @@ EXTRA_DIST = \
        pixmaps/key.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
+       pixmaps/linewrapcurrent.xpm \
        pixmaps/locked.xpm \
        pixmaps/mail_attach.xpm \
        pixmaps/mail_compose.xpm \
@@ -288,16 +307,10 @@ EXTRA_DIST = \
        pixmaps/mail_send.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
-       pixmaps/messageview_text.xpm \
-       pixmaps/mime_application_octet_stream.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -307,10 +320,23 @@ EXTRA_DIST = \
        pixmaps/notice_error.xpm \
        pixmaps/notice_note.xpm \
        pixmaps/notice_warn.xpm \
+       pixmaps/offline.xpm \
+       pixmaps/online.xpm \
        pixmaps/outbox_hrm.xpm \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
+       pixmaps/privacy_emblem_encrypted.xpm \
+       pixmaps/privacy_emblem_failed.xpm \
+       pixmaps/privacy_emblem_passed.xpm \
+       pixmaps/privacy_emblem_signed.xpm \
+       pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/regular.xpm \
@@ -322,9 +348,7 @@ EXTRA_DIST = \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -Icommon \
@@ -342,7 +366,11 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
-       $(LIBICONV)
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
+       $(PTHREAD_LIBS) \
+       $(LIBICONV) \
+       $(STARTUP_NOTIFICATION_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -354,6 +382,7 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS)
 
 AM_YFLAGS = -d