Included address harvester feature.
[claws.git] / src / Makefile.am
index 3b3bce2e53e0870c5ae766d96d719161032660f1..6b0eedb5bbb155a6df087ff18c6c296ff84cb437 100644 (file)
@@ -14,6 +14,7 @@ sylpheed_SOURCES = \
        imageview.c imageview.h \
        mimeview.c mimeview.h \
        summary_search.c summary_search.h \
+       message_search.c message_search.h \
        colorlabel.c colorlabel.h \
        folder.c folder.h \
        procmsg.c procmsg.h \
@@ -22,25 +23,37 @@ sylpheed_SOURCES = \
        compose.c compose.h \
        gtkshruler.c gtkshruler.h \
        gtksctree.c gtksctree.h \
+       gtkstext.c gtkstext.h \
        menu.c menu.h \
+       stock_pixmap.c stock_pixmap.h \
        prefs.c prefs.h \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
        prefs_display_header.c prefs_display_header.h \
        prefs_customheader.c prefs_customheader.h \
+       prefs_summary_column.c prefs_summary_column.h \
+       prefs_template.c prefs_template.h \
        account.c account.h \
        displayheader.c displayheader.h \
        customheader.c customheader.h \
+       template.c template.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
        addressitem.h \
+       adbookbase.h \
        addritem.c addritem.h \
        addrcache.c addrcache.h \
+       addrclip.c addrclip.h \
+       addrselect.c addrselect.h \
        addrbook.c addrbook.h \
        addrindex.c addrindex.h \
        mgutils.c mgutils.h \
        vcard.c vcard.h \
+       ldif.c ldif.h \
+       importldif.c importldif.h \
+       mutt.c mutt.h \
+       importmutt.c importmutt.h \
        jpilot.c jpilot.h \
        syldap.c syldap.h \
        editbook.c editbook.h \
@@ -51,13 +64,15 @@ sylpheed_SOURCES = \
        editldap.c editldap.h \
        editldap_basedn.c editldap_basedn.h \
        addressadd.c addressadd.h \
+       addrharvest.c addrharvest.h \
+       addrgather.c addrgather.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
-       headerwindow.c headerwindow.h \
        logwindow.c logwindow.h \
        sourcewindow.c sourcewindow.h \
        manage_window.c manage_window.h \
+       undo.c undo.h \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
        progressdialog.c progressdialog.h \
@@ -91,30 +106,40 @@ sylpheed_SOURCES = \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
+       enriched.c enriched.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
+       pgptext.c pgptext.h \
        select-keys.c select-keys.h \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
        stringtable.c stringtable.h \
-       gtkstext.c gtkstext.h \
        scoring.c scoring.h \
        prefs_folder_item.c prefs_folder_item.h \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
        prefs_scoring.c prefs_scoring.h \
+       prefs_actions.c prefs_actions.h \
        filtering.c filtering.h \
        prefs_filtering.c prefs_filtering.h \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
-       quote_fmt_parse.y quote_fmt.h \
+       quote_fmt_parse.y quote_fmt.c quote_fmt.h \
        gtkspell.c gtkspell.h gtkxtext.h \
-       template.c template.h \
-       prefs_templates.c prefs_templates.h \
-       template_select.c template_select.h
+       matcher_parser_lex.l matcher_parser_lex.h \
+       matcher_parser_parse.y matcher_parser.h \
+       string_match.h string_match.c \
+       selective_download.c selective_download.h
 
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h \
+       matcher_parser_lex.c \
+       matcher_parser_parse.c \
+       matcher_parser_parse.h
 
 EXTRA_DIST = \
        quote_fmt_parse.h \
@@ -128,6 +153,8 @@ EXTRA_DIST = \
        pixmaps/group.xpm \
        pixmaps/inbox.xpm \
        pixmaps/mark.xpm \
+       pixmaps/checkbox_on.xpm \
+       pixmaps/checkbox_off.xpm \
        pixmaps/new.xpm \
        pixmaps/outbox.xpm \
        pixmaps/regular.xpm \
@@ -167,7 +194,8 @@ EXTRA_DIST = \
        pixmaps/interface.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/ldap.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/locked.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -176,6 +204,7 @@ INCLUDES = \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+       $(GPGME_CFLAGS) \
         $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
@@ -191,14 +220,8 @@ sylpheed_LDADD = \
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
+       -DFAQDIR=\""$(faqdir)"\" \
        -DHOST_ALIAS=\""$(host_alias)"\" \
-       -DSYSCONFDIR=\""$(sysconfdir)"\" \
-        -DPSPELL_PATH=\""$(PSPELL_PATH)"\"
+       -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d
-
-
-BUILT_SOURCES = \
-       quote_fmt_lex.c \
-       quote_fmt_parse.c \
-       quote_fmt_parse.h