0.9.6claws61
[claws.git] / src / Makefile.am
index 4557fd9212f443ee67d5750b308578e3438ea1af..5fdc49bcb0a7cd75858e7b7546d51b48b36b6410 100644 (file)
@@ -5,10 +5,10 @@ bin_PROGRAMS = sylpheed
 sylpheed_SOURCES = \
        account.c \
        action.c \
-       addr_compl.c \
        addrbook.c \
        addrcache.c \
        addrclip.c \
+       addr_compl.c \
        addressadd.c \
        addressbook.c \
        addrgather.c \
@@ -27,8 +27,8 @@ sylpheed_SOURCES = \
        editbook.c \
        editgroup.c \
        editjpilot.c \
-       editldap.c \
        editldap_basedn.c \
+       editldap.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -64,7 +64,6 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mbox_folder.c \
        message_search.c \
        messageview.c \
        mh.c \
@@ -74,6 +73,7 @@ sylpheed_SOURCES = \
        news.c \
        noticeview.c \
        passphrase.c \
+       pgpmime.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -81,8 +81,8 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
-       prefs_filtering.c \
        prefs_filtering_action.c \
+       prefs_filtering.c \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
@@ -92,6 +92,7 @@ sylpheed_SOURCES = \
        prefs_summary_column.c \
        prefs_template.c \
        prefs_toolbar.c \
+       privacy.c \
        procheader.c \
        procmime.c \
        procmsg.c \
@@ -104,6 +105,7 @@ sylpheed_SOURCES = \
        select-keys.c \
        send_message.c \
        setup.c \
+       sgpgme.c \
        sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
@@ -124,10 +126,10 @@ sylpheedinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
-       addr_compl.h \
        addrbook.h \
        addrcache.h \
        addrclip.h \
+       addr_compl.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -147,8 +149,8 @@ sylpheedinclude_HEADERS = \
        editbook.h \
        editgroup.h \
        editjpilot.h \
-       editldap.h \
        editldap_basedn.h \
+       editldap.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -185,7 +187,6 @@ sylpheedinclude_HEADERS = \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
        mbox.h \
-       mbox_folder.h \
        message_search.h \
        messageview.h \
        mh.h \
@@ -195,6 +196,7 @@ sylpheedinclude_HEADERS = \
        news.h \
        noticeview.h \
        passphrase.h \
+       pgpmime.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -202,8 +204,8 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
-       prefs_filtering.h \
        prefs_filtering_action.h \
+       prefs_filtering.h \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
@@ -213,6 +215,7 @@ sylpheedinclude_HEADERS = \
        prefs_summary_column.h \
        prefs_template.h \
        prefs_toolbar.h \
+       privacy.h \
        procheader.h \
        procmime.h \
        procmsg.h \
@@ -225,6 +228,7 @@ sylpheedinclude_HEADERS = \
        select-keys.h \
        send_message.h \
        setup.h \
+       sgpgme.h \
        sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
@@ -290,15 +294,8 @@ EXTRA_DIST = \
        pixmaps/mail_send.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
-       pixmaps/messageview_text.xpm \
-       pixmaps/mime_application_octet_stream.xpm \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
-       pixmaps/mime_gpg_expired.xpm \
-       pixmaps/mime_gpg_failed.xpm \
-       pixmaps/mime_gpg_passed.xpm \
-       pixmaps/mime_gpg_signed.xpm \
-       pixmaps/mime_gpg_unknown.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
@@ -313,6 +310,12 @@ EXTRA_DIST = \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/privacy_expired.xpm \
+       pixmaps/privacy_failed.xpm \
+       pixmaps/privacy_passed.xpm \
+       pixmaps/privacy_signed.xpm \
+       pixmaps/privacy_unknown.xpm \
+       pixmaps/privacy_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/regular.xpm \
@@ -344,6 +347,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
        $(LIBICONV)
 
 AM_CPPFLAGS = \