Created autoconf/automake rules for the quote format parser.
[claws.git] / src / Makefile.am
index 46ad5d2d1ee2b8232d3e9a09874d196600ac8e29..5e0876495b8b32866d525dbcdb61a348354bbd97 100644 (file)
@@ -25,7 +25,11 @@ sylpheed_SOURCES = \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_display_header.c prefs_display_header.h \
+       prefs_customheader.c prefs_customheader.h \
        account.c account.h \
+       displayheader.c displayheader.h \
+       customheader.c customheader.h \
        addressbook.c addressbook.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
@@ -45,8 +49,7 @@ sylpheed_SOURCES = \
        unmime.c unmime.h \
        base64.c base64.h \
        uuencode.c uuencode.h \
-       md5c.c md5.h md5global.h \
-       md5ify.c md5ify.h \
+       md5.c md5.h \
        rfc822.c rfc822.h \
        socket.c socket.h \
        automaton.c automaton.h \
@@ -60,6 +63,7 @@ sylpheed_SOURCES = \
        recv.c recv.h \
        inc.c inc.h \
        import.c import.h \
+       export.c export.h \
        nntp.c nntp.h \
        news.c news.h \
        imap.c imap.h \
@@ -69,10 +73,22 @@ sylpheed_SOURCES = \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
        select-keys.c select-keys.h \
+       sigstatus.c sigstatus.h \
+       simple-gettext.c \
        manual.c manual.h \
        addr_compl.c addr_compl.h \
-       export.c export.h \
-       grouplist_dialog.c grouplist_dialog.h
+       gtkstext.c gtkstext.h \
+       grouplist_dialog.c grouplist_dialog.h \
+       scoring.c scoring.h \
+       prefs_folder_item.c prefs_folder_item.h \
+       matcher.c matcher.h \
+       prefs_matcher.c prefs_matcher.h \
+       prefs_scoring.c prefs_scoring.h \
+       filtering.c filtering.h \
+       prefs_filtering.c prefs_filtering.h \
+       mbox_folder.c mbox_folder.h \
+       quote_fmt_lex.l quote_fmt_lex.h \
+       quote_fmt_parse.y
 
 EXTRA_DIST = \
        pixmaps/clip.xpm \
@@ -91,6 +107,9 @@ EXTRA_DIST = \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
        pixmaps/linewrap.xpm \
+       pixmaps/continue.xpm \
+       pixmaps/complete.xpm \
+       pixmaps/error.xpm \
        pixmaps/stock_mail.xpm \
        pixmaps/stock_mail_attach.xpm \
        pixmaps/stock_mail_receive.xpm \
@@ -133,3 +152,10 @@ CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DHOST_ALIAS=\""$(host_alias)"\"
+
+YFLAGS = -d
+
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h