revise label colouring, add filter action for label colouring, fix filtering issues
[claws.git] / src / Makefile.am
index 113fce5c784a8b1ea9f6879375ebe09a99122b36..58daec120c55b6ace0cf05138f9d66e14e9957b8 100644 (file)
@@ -26,9 +26,12 @@ sylpheed_SOURCES = \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
        prefs_display_header.c prefs_display_header.h \
+       prefs_customheader.c prefs_customheader.h \
        account.c account.h \
-       displayheader.c displayheader.h \
+       displayheader.c displayheader.h \
+       customheader.c customheader.h \
        addressbook.c addressbook.h \
+       addr_compl.c addr_compl.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -39,6 +42,7 @@ sylpheed_SOURCES = \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
        progressdialog.c progressdialog.h \
+       grouplistdialog.c grouplistdialog.h \
        about.c about.h \
        setup.c setup.h \
        utils.c utils.h \
@@ -74,16 +78,31 @@ sylpheed_SOURCES = \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
-       addr_compl.c addr_compl.h \
        gtkstext.c gtkstext.h \
-       grouplist_dialog.c grouplist_dialog.h \
-       customheader.c customheader.h \
-       prefs_headers.c prefs_headers.h \
        scoring.c scoring.h \
        prefs_folder_item.c prefs_folder_item.h \
-       matcher.c matcher.h
+       matcher.c matcher.h \
+       prefs_matcher.c prefs_matcher.h \
+       prefs_scoring.c prefs_scoring.h \
+       filtering.c filtering.h \
+       prefs_filtering.c prefs_filtering.h \
+       mbox_folder.c mbox_folder.h \
+       quote_fmt_lex.l quote_fmt_lex.h \
+       quote_fmt_parse.y quote_fmt.h \
+       addressitem.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h \
+       labelcolors.c labelcolors.h \
+       ssl.c ssl.h
 
 EXTRA_DIST = \
+       quote_fmt_parse.h \
        pixmaps/clip.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir-close.xpm \
@@ -109,8 +128,10 @@ EXTRA_DIST = \
        pixmaps/stock_mail_receive_all.xpm \
        pixmaps/stock_mail_send.xpm \
        pixmaps/stock_mail_compose.xpm \
+       pixmaps/stock_news_compose.xpm \
        pixmaps/stock_mail_reply.xpm \
        pixmaps/stock_mail_reply_to_all.xpm \
+       pixmaps/stock_mail_reply_to_author.xpm \
        pixmaps/stock_mail_forward.xpm \
        pixmaps/stock_preferences.xpm \
        pixmaps/stock_properties.xpm \
@@ -122,7 +143,12 @@ EXTRA_DIST = \
        pixmaps/stock_down_arrow.xpm \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm
+       pixmaps/sylpheed-logo.xpm \
+       pixmaps/vcard.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/category.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/ignorethread.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -144,4 +170,14 @@ sylpheed_LDADD = \
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\"
+       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"
+
+YFLAGS = -d
+
+
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h
+