* src/Makefile.am
[claws.git] / src / Makefile.am
index 38977a004bd04c30b11ee4488124337c4629a25c..51e89064a1b9ea531f851f84679143909ea3e647 100644 (file)
@@ -14,6 +14,7 @@ sylpheed_SOURCES = \
        imageview.c imageview.h \
        mimeview.c mimeview.h \
        summary_search.c summary_search.h \
+       message_search.c message_search.h \
        colorlabel.c colorlabel.h \
        folder.c folder.h \
        procmsg.c procmsg.h \
@@ -22,25 +23,40 @@ sylpheed_SOURCES = \
        compose.c compose.h \
        gtkshruler.c gtkshruler.h \
        gtksctree.c gtksctree.h \
+       gtkstext.c gtkstext.h \
        menu.c menu.h \
+       stock_pixmap.c stock_pixmap.h \
        prefs.c prefs.h \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_folder_item.c prefs_folder_item.h \
        prefs_display_header.c prefs_display_header.h \
        prefs_customheader.c prefs_customheader.h \
+       prefs_summary_column.c prefs_summary_column.h \
+       prefs_template.c prefs_template.h \
        account.c account.h \
        displayheader.c displayheader.h \
        customheader.c customheader.h \
+       template.c template.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
        addressitem.h \
+       adbookbase.h \
        addritem.c addritem.h \
        addrcache.c addrcache.h \
+       addrclip.c addrclip.h \
+       addrselect.c addrselect.h \
        addrbook.c addrbook.h \
        addrindex.c addrindex.h \
        mgutils.c mgutils.h \
        vcard.c vcard.h \
+       ldif.c ldif.h \
+       importldif.c importldif.h \
+       mutt.c mutt.h \
+       importmutt.c importmutt.h \
+       pine.c pine.h \
+       importpine.c importpine.h \
        jpilot.c jpilot.h \
        syldap.c syldap.h \
        editbook.c editbook.h \
@@ -51,13 +67,18 @@ sylpheed_SOURCES = \
        editldap.c editldap.h \
        editldap_basedn.c editldap_basedn.h \
        addressadd.c addressadd.h \
+       addrharvest.c addrharvest.h \
+       addrgather.c addrgather.h \
+       exporthtml.c exporthtml.h \
+       exphtmldlg.c exphtmldlg.h \
+       xmlprops.c xmlprops.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
-       headerwindow.c headerwindow.h \
        logwindow.c logwindow.h \
        sourcewindow.c sourcewindow.h \
        manage_window.c manage_window.h \
+       undo.c undo.h \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
        progressdialog.c progressdialog.h \
@@ -77,7 +98,6 @@ sylpheed_SOURCES = \
        automaton.c automaton.h \
        session.c session.h \
        smtp.c smtp.h \
-       esmtp.c esmtp.h \
        pop.c pop.h \
        mh.c mh.h \
        mbox.c mbox.h \
@@ -91,83 +111,104 @@ sylpheed_SOURCES = \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
+       enriched.c enriched.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
+       pgptext.c pgptext.h \
        select-keys.c select-keys.h \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
        stringtable.c stringtable.h \
-       gtkstext.c gtkstext.h \
        scoring.c scoring.h \
-       prefs_folder_item.c prefs_folder_item.h \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
        prefs_scoring.c prefs_scoring.h \
+       prefs_actions.c prefs_actions.h \
        filtering.c filtering.h \
        prefs_filtering.c prefs_filtering.h \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
-       quote_fmt_parse.y quote_fmt.h \
+       quote_fmt_parse.y quote_fmt.c quote_fmt.h \
        gtkspell.c gtkspell.h gtkxtext.h \
-       template.c template.h \
-       prefs_templates.c prefs_templates.h \
-       template_select.c template_select.h
+       matcher_parser_lex.l matcher_parser_lex.h \
+       matcher_parser_parse.y matcher_parser.h \
+       string_match.h string_match.c \
+       selective_download.c selective_download.h
 
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h \
+       matcher_parser_lex.c \
+       matcher_parser_parse.c \
+       matcher_parser_parse.h
 
 EXTRA_DIST = \
        quote_fmt_parse.h \
        version.h.in \
+       pixmaps/address_book.xpm \
+       pixmaps/address.xpm \
+       pixmaps/book.xpm \
+       pixmaps/category.xpm \
+       pixmaps/checkbox_off.xpm \
+       pixmaps/checkbox_on.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clipkey.xpm \
+       pixmaps/close.xpm \
+       pixmaps/complete.xpm \
+       pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
-       pixmaps/dir-close.xpm \
-       pixmaps/dir-open.xpm \
+       pixmaps/dir_close.xpm \
+       pixmaps/dir_open.xpm \
+       pixmaps/dir_open_hrm.xpm \
+       pixmaps/down_arrow.xpm \
+       pixmaps/error.xpm \
+       pixmaps/exec.xpm \
        pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/group.xpm \
+       pixmaps/ignorethread.xpm \
        pixmaps/inbox.xpm \
+       pixmaps/inbox_hrm.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/key.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/linewrap.xpm \
+       pixmaps/locked.xpm \
+       pixmaps/mail.xpm \
+       pixmaps/mail_attach.xpm \
+       pixmaps/mail_compose.xpm \
+       pixmaps/mail_forward.xpm \
+       pixmaps/mail_receive.xpm \
+       pixmaps/mail_receive_all.xpm \
+       pixmaps/mail_reply.xpm \
+       pixmaps/mail_reply_to_all.xpm \
+       pixmaps/mail_reply_to_author.xpm \
+       pixmaps/mail_send.xpm \
+       pixmaps/mail_send_queue.xpm \
        pixmaps/mark.xpm \
        pixmaps/new.xpm \
+       pixmaps/news_compose.xpm \
        pixmaps/outbox.xpm \
+       pixmaps/outbox_hrm.xpm \
+       pixmaps/paste.xpm \
+       pixmaps/preferences.xpm \
+       pixmaps/properties.xpm \
        pixmaps/regular.xpm \
        pixmaps/replied.xpm \
+       pixmaps/search.xpm \
+       pixmaps/sylpheed.xpm \
+       pixmaps/sylpheed_logo.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_hrm.xpm \
        pixmaps/unread.xpm \
-       pixmaps/linewrap.xpm \
-       pixmaps/continue.xpm \
-       pixmaps/complete.xpm \
-       pixmaps/error.xpm \
-       pixmaps/stock_mail.xpm \
-       pixmaps/stock_mail_attach.xpm \
-       pixmaps/stock_mail_receive.xpm \
-       pixmaps/stock_mail_receive_all.xpm \
-       pixmaps/stock_mail_send.xpm \
-       pixmaps/stock_mail_send_queue.xpm \
-       pixmaps/stock_mail_compose.xpm \
-       pixmaps/stock_news_compose.xpm \
-       pixmaps/stock_mail_reply.xpm \
-       pixmaps/stock_mail_reply_to_all.xpm \
-       pixmaps/stock_mail_reply_to_author.xpm \
-       pixmaps/stock_mail_forward.xpm \
-       pixmaps/stock_preferences.xpm \
-       pixmaps/stock_properties.xpm \
-       pixmaps/stock_search.xpm \
-       pixmaps/stock_close.xpm \
-       pixmaps/stock_exec.xpm \
-       pixmaps/stock_trash.xpm \
-       pixmaps/stock_up_arrow.xpm \
-       pixmaps/stock_down_arrow.xpm \
-       pixmaps/stock_paste.xpm \
-       pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm \
-       pixmaps/address.xpm \
-       pixmaps/book.xpm \
-       pixmaps/category.xpm \
-       pixmaps/interface.xpm \
-       pixmaps/jpilot.xpm \
-       pixmaps/ldap.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/up_arrow.xpm \
+       pixmaps/vcard.xpm \
+       pixmaps/work_offline.xpm \
+       pixmaps/work_online.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -176,6 +217,8 @@ INCLUDES = \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+       $(GPGME_CFLAGS) \
+        $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
 sylpheed_LDADD = \
@@ -184,19 +227,14 @@ sylpheed_LDADD = \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
-       $(GPGME_LIBS)
+       $(GPGME_LIBS) \
+        $(PSPELL_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
+       -DFAQDIR=\""$(faqdir)"\" \
        -DHOST_ALIAS=\""$(host_alias)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d
-
-
-BUILT_SOURCES = \
-       quote_fmt_lex.c \
-       quote_fmt_parse.c \
-       quote_fmt_parse.h
-