easy to forget this...
[claws.git] / src / Makefile.am
index 220e6c31b77124f9862591445cedfcd4bcebdfdf..40f5f1118f78eaf770d30cca6f887e8b146e9697 100644 (file)
@@ -30,10 +30,12 @@ sylpheed_SOURCES = \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_folder_item.c prefs_folder_item.h \
        prefs_display_header.c prefs_display_header.h \
        prefs_customheader.c prefs_customheader.h \
        prefs_summary_column.c prefs_summary_column.h \
        prefs_template.c prefs_template.h \
+       prefs_actions.c prefs_actions.h \
        account.c account.h \
        displayheader.c displayheader.h \
        customheader.c customheader.h \
@@ -68,6 +70,9 @@ sylpheed_SOURCES = \
        addressadd.c addressadd.h \
        addrharvest.c addrharvest.h \
        addrgather.c addrgather.h \
+       exporthtml.c exporthtml.h \
+       exphtmldlg.c exphtmldlg.h \
+       xmlprops.c xmlprops.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -118,11 +123,9 @@ sylpheed_SOURCES = \
        manual.c manual.h \
        stringtable.c stringtable.h \
        scoring.c scoring.h \
-       prefs_folder_item.c prefs_folder_item.h \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
        prefs_scoring.c prefs_scoring.h \
-       prefs_actions.c prefs_actions.h \
        filtering.c filtering.h \
        prefs_filtering.c prefs_filtering.h \
        mbox_folder.c mbox_folder.h \
@@ -130,9 +133,11 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y quote_fmt.c quote_fmt.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        matcher_parser_lex.l matcher_parser_lex.h \
-       matcher_parser_parse.y matcher_parser.h \
+       matcher_parser_parse.y matcher_parser.h matcher_parser_parse.h \
        string_match.h string_match.c \
-       selective_download.c selective_download.h
+       selective_download.c selective_download.h \
+       msgcache.h msgcache.c \
+       noticeview.h noticeview.c
 
 BUILT_SOURCES = \
        quote_fmt_lex.c \
@@ -145,62 +150,73 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        quote_fmt_parse.h \
        version.h.in \
+       pixmaps/address_book.xpm \
+       pixmaps/address.xpm \
+       pixmaps/book.xpm \
+       pixmaps/category.xpm \
+       pixmaps/checkbox_off.xpm \
+       pixmaps/checkbox_on.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clipkey.xpm \
+       pixmaps/close.xpm \
+       pixmaps/complete.xpm \
+       pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
-       pixmaps/dir-close.xpm \
-       pixmaps/dir-open.xpm \
+       pixmaps/dir_close.xpm \
+       pixmaps/dir_open.xpm \
+       pixmaps/dir_open_hrm.xpm \
+       pixmaps/down_arrow.xpm \
+       pixmaps/error.xpm \
+       pixmaps/exec.xpm \
        pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/group.xpm \
+       pixmaps/ignorethread.xpm \
        pixmaps/inbox.xpm \
+       pixmaps/inbox_hrm.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/key.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/linewrap.xpm \
+       pixmaps/locked.xpm \
+       pixmaps/mail.xpm \
+       pixmaps/mail_attach.xpm \
+       pixmaps/mail_compose.xpm \
+       pixmaps/mail_forward.xpm \
+       pixmaps/mail_receive.xpm \
+       pixmaps/mail_receive_all.xpm \
+       pixmaps/mail_reply.xpm \
+       pixmaps/mail_reply_to_all.xpm \
+       pixmaps/mail_reply_to_author.xpm \
+       pixmaps/mail_send.xpm \
+       pixmaps/mail_send_queue.xpm \
        pixmaps/mark.xpm \
-       pixmaps/checkbox_on.xpm \
-       pixmaps/checkbox_off.xpm \
        pixmaps/new.xpm \
+       pixmaps/news_compose.xpm \
        pixmaps/outbox.xpm \
+       pixmaps/outbox_hrm.xpm \
+       pixmaps/paste.xpm \
+       pixmaps/preferences.xpm \
+       pixmaps/properties.xpm \
        pixmaps/regular.xpm \
        pixmaps/replied.xpm \
+       pixmaps/search.xpm \
+       pixmaps/sylpheed.xpm \
+       pixmaps/sylpheed_logo.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_hrm.xpm \
        pixmaps/unread.xpm \
-       pixmaps/linewrap.xpm \
-       pixmaps/continue.xpm \
-       pixmaps/complete.xpm \
-       pixmaps/error.xpm \
-       pixmaps/stock_mail.xpm \
-       pixmaps/stock_mail_attach.xpm \
-       pixmaps/stock_mail_receive.xpm \
-       pixmaps/stock_mail_receive_all.xpm \
-       pixmaps/stock_mail_send.xpm \
-       pixmaps/stock_mail_send_queue.xpm \
-       pixmaps/stock_mail_compose.xpm \
-       pixmaps/stock_news_compose.xpm \
-       pixmaps/stock_mail_reply.xpm \
-       pixmaps/stock_mail_reply_to_all.xpm \
-       pixmaps/stock_mail_reply_to_author.xpm \
-       pixmaps/stock_mail_forward.xpm \
-       pixmaps/stock_preferences.xpm \
-       pixmaps/stock_properties.xpm \
-       pixmaps/stock_search.xpm \
-       pixmaps/stock_close.xpm \
-       pixmaps/stock_exec.xpm \
-       pixmaps/stock_trash.xpm \
-       pixmaps/stock_up_arrow.xpm \
-       pixmaps/stock_down_arrow.xpm \
-       pixmaps/stock_paste.xpm \
-       pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm \
-       pixmaps/address.xpm \
-       pixmaps/book.xpm \
-       pixmaps/category.xpm \
-       pixmaps/interface.xpm \
-       pixmaps/jpilot.xpm \
-       pixmaps/ldap.xpm \
+       pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
-       pixmaps/locked.xpm
+       pixmaps/work_offline.xpm \
+       pixmaps/work_online.xpm \
+       pixmaps/notice_warn.xpm \
+       pixmaps/notice_error.xpm \
+       pixmaps/notice_note.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
-       -I$(top_srcdir)/libkcc \
        -I$(top_srcdir)/intl \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
@@ -210,19 +226,19 @@ INCLUDES = \
        -I$(includedir)
 
 sylpheed_LDADD = \
-       $(top_builddir)/libkcc/libkcc.a \
        $(INTLLIBS) \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
        $(GPGME_LIBS) \
-        $(PSPELL_LIBS)
+        $(PSPELL_LIBS) \
+       $(LDAP_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DTARGET_ALIAS=\""$(target_alias)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d