2006-02-24 [colin] 2.0.0cvs82
[claws.git] / src / Makefile.am
index 0b70532e1b70e5917b8fa14793a47ce28a03b5b4..345d65d91c5a0728d538ea08b56442e5df0789f7 100644 (file)
@@ -1,8 +1,17 @@
-SUBDIRS = common gtk plugins
 
-bin_PROGRAMS = sylpheed
+if SYLPHEED_LIBETPAN
+etpan_dir = etpan
+etpan_library = etpan/libsylpheedetpan.la
+else
+etpan_dir =
+etpan_library = 
+endif
 
-sylpheed_SOURCES = \
+SUBDIRS = common gtk plugins $(etpan_dir)
+
+bin_PROGRAMS = sylpheed-claws
+
+sylpheed_claws_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -43,6 +52,7 @@ sylpheed_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
@@ -96,9 +106,16 @@ sylpheed_SOURCES = \
        prefs_gtk.c \
        prefs_image_viewer.c \
        prefs_matcher.c \
+       prefs_message.c \
        prefs_msg_colors.c \
+       prefs_other.c \
+       prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
+       prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
@@ -128,8 +145,8 @@ sylpheed_SOURCES = \
        vcard.c \
        wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+sylpheed_clawsincludedir = $(pkgincludedir)
+sylpheed_clawsinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -173,6 +190,7 @@ sylpheedinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
@@ -227,9 +245,16 @@ sylpheedinclude_HEADERS = \
        prefs_gtk.h \
        prefs_image_viewer.h \
        prefs_matcher.h \
+       prefs_message.h \
        prefs_msg_colors.h \
+       prefs_other.h \
+       prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
+       prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
@@ -346,24 +371,47 @@ EXTRA_DIST = \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/spam.xpm \
        pixmaps/sylpheed_icon.xpm \
        pixmaps/sylpheed_logo.xpm \
        pixmaps/sylpheed.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
        pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
-       -Icommon \
-       -Igtk
+       -I$(srcdir)/common \
+       -I$(srcdir)/gtk \
+       -I$(srcdir)/etpan
+
+if PLATFORM_WIN32
+arch_ldflags := -export-all-symbols
+else
+arch_ldflags :=
+endif
 
-sylpheed_LDFLAGS = \
-       -export-dynamic
+sylpheed_claws_LDFLAGS = \
+       $(arch_ldflags) -export-dynamic
 
-sylpheed_LDADD = \
+sylpheed_claws_LDADD = \
+       $(etpan_library) \
        gtk/libsylpheedgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
@@ -374,11 +422,13 @@ sylpheed_LDADD = \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
        $(LIBICONV) \
-       $(STARTUP_NOTIFICATION_LIBS)
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -388,6 +438,13 @@ AM_CPPFLAGS = \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(OPENSSL_CFLAGS) \
-       $(STARTUP_NOTIFICATION_CFLAGS)
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
 AM_YFLAGS = -d