inital gtk2 patch
[claws.git] / src / Makefile.am
index 0926c0d8571ba0835265d732ff2d1891086563b9..320f1a80617f6ff676fc08add87d081cfaddaede 100644 (file)
@@ -1,5 +1,19 @@
 SUBDIRS = common gtk plugins
 
+
+if PLATFORM_WIN32
+
+SYLPHEED_RES = sylpheed.res
+
+sylpheed.rc:
+       echo "SYLPHEED ICON sylpheed.ico" > sylpheed.rc
+
+sylpheed.res: sylpheed.rc
+       $(WINDRES) $< -O coff -o $@
+
+endif
+
+
 bin_PROGRAMS = sylpheed
 
 sylpheed_SOURCES = \
@@ -15,6 +29,7 @@ sylpheed_SOURCES = \
        addrharvest.c \
        addrindex.c \
        addritem.c \
+       addrquery.c \
        addrselect.c \
        alertpanel.c \
        codeconv.c \
@@ -152,8 +167,10 @@ sylpheedinclude_HEADERS = \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
+       expldifdlg.h \
        export.h \
        exporthtml.h \
+       exportldif.h \
        filtering.h \
        folder.h \
        folder_item_prefs.h \
@@ -243,7 +260,9 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
+       sylpheed.ico \
        pixmaps/address_book.xpm \
+       pixmaps/address_search.xpm \
        pixmaps/address.xpm \
        pixmaps/book.xpm \
        pixmaps/category.xpm \
@@ -342,7 +361,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
-       $(LIBICONV)
+       $(LIBICONV) \
+       $(SYLPHEED_RES)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \