2004-12-04 [paul] 0.9.12cvs182.2
[claws.git] / src / Makefile.am
index 2a40d99ca93957d4665a362bb5b1403fafcb9949..2f88d93b9fb85b2854c857dbfc7c86278cc92db6 100644 (file)
@@ -78,8 +78,7 @@ sylpheed_SOURCES = \
        news.c \
        news_gtk.c \
        noticeview.c \
-       passphrase.c \
-       pgpmime.c \
+       partial_download.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -94,11 +93,13 @@ sylpheed_SOURCES = \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
+       prefs_msg_colors.c \
        prefs_spelling.c \
        prefs_summary_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
+       prefs_wrapping.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -108,11 +109,8 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y \
        recv.c \
        remotefolder.c \
-       rfc2015.c \
-       select-keys.c \
        send_message.c \
        setup.c \
-       sgpgme.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -124,7 +122,8 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
-       vcard.c
+       vcard.c \
+       wizard.c
 
 sylpheedincludedir = $(pkgincludedir)
 sylpheedinclude_HEADERS = \
@@ -207,8 +206,7 @@ sylpheedinclude_HEADERS = \
        news.h \
        news_gtk.h \
        noticeview.h \
-       passphrase.h \
-       pgpmime.h \
+       partial_download.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -223,11 +221,13 @@ sylpheedinclude_HEADERS = \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
+       prefs_msg_colors.h \
        prefs_spelling.h \
        prefs_summary_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
+       prefs_wrapping.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -237,11 +237,8 @@ sylpheedinclude_HEADERS = \
        quote_fmt_parse.h \
        recv.h \
        remotefolder.h \
-       rfc2015.h \
-       select-keys.h \
        send_message.h \
        setup.h \
-       sgpgme.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -252,7 +249,8 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
-       vcard.h
+       vcard.h \
+       wizard.h
 
 BUILT_SOURCES = \
        matcher_parser_parse.h \
@@ -281,7 +279,6 @@ EXTRA_DIST = \
        pixmaps/drafts_open.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
-       pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
@@ -332,16 +329,22 @@ EXTRA_DIST = \
        pixmaps/privacy_signed.xpm \
        pixmaps/privacy_unknown.xpm \
        pixmaps/privacy_warn.xpm \
+       pixmaps/privacy_emblem_encrypted.xpm \
+       pixmaps/privacy_emblem_failed.xpm \
+       pixmaps/privacy_emblem_passed.xpm \
+       pixmaps/privacy_emblem_signed.xpm \
+       pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
-       pixmaps/regular.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/sylpheed_icon.xpm \
        pixmaps/sylpheed_logo.xpm \
        pixmaps/sylpheed.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
+       pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm
 
@@ -363,7 +366,9 @@ sylpheed_LDADD = \
        $(OPENSSL_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
-       $(LIBICONV)
+       $(PTHREAD_LIBS) \
+       $(LIBICONV) \
+       $(STARTUP_NOTIFICATION_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -375,6 +380,7 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS)
 
 AM_YFLAGS = -d