2007-07-19 [paul] 2.10.0cvs46
[claws.git] / src / Makefile.am
index faef2f26487b7df51b80349927a76d91ea6b1979..2e0f8f11af0879693602069172794cbcd0b6220f 100644 (file)
@@ -38,11 +38,13 @@ claws_mail_SOURCES = \
        customheader.c \
        displayheader.c \
        editaddress.c \
+       editaddress_other_attributes_ldap.c \
        editbook.c \
        editgroup.c \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
+       edittags.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -73,6 +75,7 @@ claws_mail_SOURCES = \
        ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
+       ldapupdate.c \
        ldaputil.c \
        ldif.c \
        localfolder.c \
@@ -109,6 +112,7 @@ claws_mail_SOURCES = \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_image_viewer.c \
+       prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
        prefs_msg_colors.c \
@@ -119,6 +123,7 @@ claws_mail_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
@@ -178,11 +183,13 @@ claws_mailinclude_HEADERS = \
        customheader.h \
        displayheader.h \
        editaddress.h \
+       editaddress_other_attributes_ldap.h \
        editbook.h \
        editgroup.h \
        editjpilot.h \
        editldap_basedn.h \
        editldap.h \
+       edittags.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -213,6 +220,7 @@ claws_mailinclude_HEADERS = \
        ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
+       ldapupdate.h \
        ldaputil.h \
        ldif.h \
        localfolder.h \
@@ -250,6 +258,7 @@ claws_mailinclude_HEADERS = \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_image_viewer.h \
+       prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
        prefs_msg_colors.h \
@@ -260,6 +269,7 @@ claws_mailinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
@@ -295,7 +305,6 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       pixmaps/active.xpm \
        pixmaps/addr_one.xpm \
        pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
@@ -314,22 +323,28 @@ EXTRA_DIST = \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
+       pixmaps/dir_close_hrm.xpm \
        pixmaps/dir_noselect.xpm \
-        pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
+       pixmaps/drafts_close.xpm \
+       pixmaps/drafts_open.xpm \
+       pixmaps/edit_extern.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
+       pixmaps/go_folders.xpm \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inactive.xpm \
-       pixmaps/inbox_hrm.xpm \
-       pixmaps/inbox.xpm \
+       pixmaps/inbox_open_hrm.xpm \
+       pixmaps/inbox_open.xpm \
+       pixmaps/inbox_close_hrm.xpm \
+       pixmaps/inbox_close.xpm \
        pixmaps/interface.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
@@ -347,6 +362,7 @@ EXTRA_DIST = \
        pixmaps/mail_reply.xpm \
        pixmaps/mail_send_queue.xpm \
        pixmaps/mail_send.xpm \
+       pixmaps/mail_sign.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
        pixmaps/mime_application.xpm \
@@ -356,6 +372,7 @@ EXTRA_DIST = \
        pixmaps/mime_pdf.xpm \
        pixmaps/mime_ps.xpm \
        pixmaps/mime_calendar.xpm \
+       pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -367,10 +384,18 @@ EXTRA_DIST = \
        pixmaps/notice_warn.xpm \
        pixmaps/offline.xpm \
        pixmaps/online.xpm \
-       pixmaps/outbox_hrm.xpm \
-       pixmaps/outbox.xpm \
+       pixmaps/open_mail.xpm \
+       pixmaps/outbox_close.xpm \
+       pixmaps/outbox_close_hrm.xpm \
+       pixmaps/outbox_open.xpm \
+       pixmaps/outbox_open_hrm.xpm \
+       pixmaps/outbox_close_mark.xpm \
+       pixmaps/outbox_close_hrm_mark.xpm \
+       pixmaps/outbox_open_mark.xpm \
+       pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -383,13 +408,23 @@ EXTRA_DIST = \
        pixmaps/privacy_emblem_signed.xpm \
        pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
+       pixmaps/queue_close.xpm \
+       pixmaps/queue_close_hrm.xpm \
+       pixmaps/queue_close_hrm_mark.xpm \
+       pixmaps/queue_close_mark.xpm \
+       pixmaps/queue_open.xpm \
+       pixmaps/queue_open_hrm.xpm \
+       pixmaps/queue_open_hrm_mark.xpm \
+       pixmaps/queue_open_mark.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/selection.xpm \
        pixmaps/spam.xpm \
        pixmaps/spam_btn.xpm \
        pixmaps/claws-mail_icon.xpm \
        pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
@@ -399,14 +434,15 @@ EXTRA_DIST = \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
        pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_close_hrm_mark.xpm \
        pixmaps/dir_open_hrm_mark.xpm \
        pixmaps/dir_open_mark.xpm \
        pixmaps/drafts_close_mark.xpm \
        pixmaps/drafts_open_mark.xpm \
-       pixmaps/inbox_hrm_mark.xpm \
-       pixmaps/inbox_mark.xpm \
-       pixmaps/outbox_hrm_mark.xpm \
-       pixmaps/outbox_mark.xpm \
+       pixmaps/inbox_open_hrm_mark.xpm \
+       pixmaps/inbox_open_mark.xpm \
+       pixmaps/inbox_close_hrm_mark.xpm \
+       pixmaps/inbox_close_mark.xpm \
        pixmaps/trash_hrm_mark.xpm \
        pixmaps/trash_mark.xpm \
        pixmaps/moved.xpm \
@@ -416,6 +452,7 @@ EXTRA_DIST = \
 
 INCLUDES = \
        -I$(srcdir)/common \
+       -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
@@ -444,7 +481,9 @@ claws_mail_LDADD = \
        $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
-       $(LIBETPAN_LIBS)
+       $(LIBETPAN_LIBS) \
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Claws-Mail\" \
@@ -453,6 +492,7 @@ AM_CPPFLAGS = \
        -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
@@ -460,6 +500,8 @@ AM_CPPFLAGS = \
        $(GNOMEPRINT_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
+       $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
        -Wno-unused-function
         
 #no-unused-function is there because of bison stuff