2007-07-19 [paul] 2.10.0cvs46
[claws.git] / src / Makefile.am
index 9760e738f742d08e29df05011d6974c3668a858b..2e0f8f11af0879693602069172794cbcd0b6220f 100644 (file)
@@ -38,11 +38,13 @@ claws_mail_SOURCES = \
        customheader.c \
        displayheader.c \
        editaddress.c \
+       editaddress_other_attributes_ldap.c \
        editbook.c \
        editgroup.c \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
+       edittags.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -121,6 +123,7 @@ claws_mail_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
@@ -180,11 +183,13 @@ claws_mailinclude_HEADERS = \
        customheader.h \
        displayheader.h \
        editaddress.h \
+       editaddress_other_attributes_ldap.h \
        editbook.h \
        editgroup.h \
        editjpilot.h \
        editldap_basedn.h \
        editldap.h \
+       edittags.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -264,6 +269,7 @@ claws_mailinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
@@ -299,7 +305,6 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       pixmaps/active.xpm \
        pixmaps/addr_one.xpm \
        pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
@@ -320,7 +325,7 @@ EXTRA_DIST = \
        pixmaps/dir_close.xpm \
        pixmaps/dir_close_hrm.xpm \
        pixmaps/dir_noselect.xpm \
-    pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
@@ -332,10 +337,10 @@ EXTRA_DIST = \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
+       pixmaps/go_folders.xpm \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inactive.xpm \
        pixmaps/inbox_open_hrm.xpm \
        pixmaps/inbox_open.xpm \
        pixmaps/inbox_close_hrm.xpm \
@@ -390,6 +395,7 @@ EXTRA_DIST = \
        pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -413,10 +419,12 @@ EXTRA_DIST = \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/selection.xpm \
        pixmaps/spam.xpm \
        pixmaps/spam_btn.xpm \
        pixmaps/claws-mail_icon.xpm \
        pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
@@ -444,6 +452,7 @@ EXTRA_DIST = \
 
 INCLUDES = \
        -I$(srcdir)/common \
+       -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
@@ -473,7 +482,8 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS)
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Claws-Mail\" \
@@ -491,6 +501,7 @@ AM_CPPFLAGS = \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
        $(MAEMO_CFLAGS) \
+       $(CONIC_CFLAGS) \
        -Wno-unused-function
         
 #no-unused-function is there because of bison stuff