remove long forgotten FAQDIR
[claws.git] / src / Makefile.am
index e0d1d5daa9396d24f4f987729d0db1f13710173c..13513d38fdade8ce5f8ef41dbc8c00abe2117227 100644 (file)
@@ -16,7 +16,7 @@ install-exec-hook:
 
 if PLATFORM_WIN32
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -102,6 +102,7 @@ abook_headers = \
        expldifdlg.h \
        exporthtml.h \
        exportldif.h \
+       file_checker.h \
        importldif.h \
        importmutt.h \
        importpine.h \
@@ -129,6 +130,7 @@ claws_mail_SOURCES = \
        advsearch.c \
        alertpanel.c \
        autofaces.c \
+       avatars.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -137,6 +139,7 @@ claws_mail_SOURCES = \
        edittags.c \
        enriched.c \
        export.c \
+        file_checker.c \
        filtering.c \
        folder.c \
        folder_item_prefs.c \
@@ -242,6 +245,7 @@ claws_mailinclude_HEADERS = \
        advsearch.h \
        alertpanel.h \
        autofaces.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -525,7 +529,7 @@ EXTRA_DIST = \
        $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
@@ -560,8 +564,6 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
        $(DBUS_LIBS) \
        $(CONTACTS_LIBS)
 
@@ -572,17 +574,15 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(IFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(DBUS_CFLAGS) \
        $(NETWORKMANAGER_SUPPORT_CFLAGS) \
        $(VALGRIND_CFLAGS) \