sync with 0.9.7cvs8
[claws.git] / src / Makefile.am
index c6bfdbec82d751046a9cfbfa3f7c31fb138cc43e..11fd5414c19097d0b9f7695f41839030cd7bf74b 100644 (file)
@@ -18,8 +18,7 @@ sylpheed_SOURCES = \
        addrquery.c \
        addrselect.c \
        alertpanel.c \
-       carray.c \
-       chash.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -55,11 +54,11 @@ sylpheed_SOURCES = \
        inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
        ldif.c \
-       maillock.c \
        main.c \
        mainwindow.c \
        manual.c \
@@ -67,10 +66,6 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l \
        matcher_parser_parse.y \
        mbox.c \
-       mailmbox_folder.c \
-       mailmbox.c \
-       mailmbox_parse.c \
-       mailmbox_types.c \
        message_search.c \
        messageview.c \
        mh.c \
@@ -94,7 +89,6 @@ sylpheed_SOURCES = \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
-       prefs_scoring.c \
        prefs_spelling.c \
        prefs_summary_column.c \
        prefs_template.c \
@@ -108,12 +102,10 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y \
        recv.c \
        rfc2015.c \
-       scoring.c \
        select-keys.c \
        send_message.c \
        setup.c \
        sgpgme.c \
-       sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -126,6 +118,8 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       localfolder.c \
+       remotefolder.c \
        vcard.c
 
 sylpheedincludedir = $(pkgincludedir)
@@ -137,6 +131,7 @@ sylpheedinclude_HEADERS = \
        addrcache.h \
        addrclip.h \
        addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -147,8 +142,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
-       carray.h \
-       chash.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -184,11 +178,11 @@ sylpheedinclude_HEADERS = \
        inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
        ldif.h \
-       maillock.h \
        main.h \
        mainwindow.h \
        manual.h \
@@ -197,10 +191,6 @@ sylpheedinclude_HEADERS = \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
        mbox.h \
-       mailmbox_folder.h \
-       mailmbox.h \
-       mailmbox_parse.h \
-       mailmbox_types.h \
        message_search.h \
        messageview.h \
        mh.h \
@@ -224,7 +214,6 @@ sylpheedinclude_HEADERS = \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
-       prefs_scoring.h \
        prefs_spelling.h \
        prefs_summary_column.h \
        prefs_template.h \
@@ -238,12 +227,10 @@ sylpheedinclude_HEADERS = \
        quote_fmt_parse.h \
        recv.h \
        rfc2015.h \
-       scoring.h \
        select-keys.h \
        send_message.h \
        setup.h \
        sgpgme.h \
-       sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -255,6 +242,8 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       localfolder.h \
+       remotefolder.h \
        vcard.h
 
 BUILT_SOURCES = \
@@ -269,6 +258,7 @@ EXTRA_DIST = \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
        pixmaps/close.xpm \
@@ -311,6 +301,7 @@ EXTRA_DIST = \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -320,6 +311,8 @@ EXTRA_DIST = \
        pixmaps/notice_error.xpm \
        pixmaps/notice_note.xpm \
        pixmaps/notice_warn.xpm \
+       pixmaps/offline.xpm \
+       pixmaps/online.xpm \
        pixmaps/outbox_hrm.xpm \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
@@ -341,9 +334,7 @@ EXTRA_DIST = \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -Icommon \
@@ -361,6 +352,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
        $(LIBICONV)
 
 AM_CPPFLAGS = \