dropped PSPELL_PATH macro
[claws.git] / src / Makefile.am
index 413637a2e889f57a9cc98c82be94b32ba27d7f11..024f8a6705a3a1283597107df465e22ecdf976b5 100644 (file)
@@ -3,6 +3,7 @@ bin_PROGRAMS = sylpheed
 sylpheed_SOURCES = \
        intl.h \
        defs.h \
+       version.h \
        main.c main.h \
        mainwindow.c mainwindow.h \
        folderview.c folderview.h \
@@ -33,6 +34,23 @@ sylpheed_SOURCES = \
        customheader.c customheader.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
+       addressitem.h \
+       addritem.c addritem.h \
+       addrcache.c addrcache.h \
+       addrbook.c addrbook.h \
+       addrindex.c addrindex.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editbook.c editbook.h \
+       editgroup.c editgroup.h \
+       editaddress.c editaddress.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h \
+       addressadd.c addressadd.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -92,15 +110,6 @@ sylpheed_SOURCES = \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
        quote_fmt_parse.y quote_fmt.h \
-       addressitem.h \
-       mgutils.c mgutils.h \
-       vcard.c vcard.h \
-       jpilot.c jpilot.h \
-       syldap.c syldap.h \
-       editvcard.c editvcard.h \
-       editjpilot.c editjpilot.h \
-       editldap.c editldap.h \
-       editldap_basedn.c editldap_basedn.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        template.c template.h \
        prefs_templates.c prefs_templates.h \
@@ -109,6 +118,7 @@ sylpheed_SOURCES = \
 
 EXTRA_DIST = \
        quote_fmt_parse.h \
+       version.h.in \
        pixmaps/clip.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir-close.xpm \
@@ -151,11 +161,13 @@ EXTRA_DIST = \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
        pixmaps/sylpheed-logo.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/jpilot.xpm \
+       pixmaps/address.xpm \
+       pixmaps/book.xpm \
        pixmaps/category.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
        pixmaps/ldap.xpm \
-       pixmaps/ignorethread.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -164,6 +176,7 @@ INCLUDES = \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+        $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
 sylpheed_LDADD = \
@@ -172,7 +185,8 @@ sylpheed_LDADD = \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
-       $(GPGME_LIBS)
+       $(GPGME_LIBS) \
+        $(PSPELL_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
@@ -187,4 +201,3 @@ BUILT_SOURCES = \
        quote_fmt_lex.c \
        quote_fmt_parse.c \
        quote_fmt_parse.h
-