Use pre-defined make variables instead of hardcoded docbook2X and sed commands.
[claws.git] / manual / es / dist / pdf / Makefile.am
index 8f9a3c29a04941128c227e6a03660eee75291761..10be1b3ecb7cc04d502246e47e84709162f62662 100644 (file)
@@ -1,8 +1,14 @@
-EXTRA_DIST=sylpheed-claws-manual.pdf
-manuales_DATA=sylpheed-claws-manual.pdf
-manualesdir=$(manualdir)/es
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
-sylpheed-claws-manual.pdf: \
+if MANUAL_PDF
+EXTRA_DIST=claws-mail-manual.pdf
+manualde_DATA=claws-mail-manual.pdf
+manualdedir=$(manualdir)/es
+
+claws-mail-manual.pdf: \
        ../../account.xml \
        ../../ack.xml \
        ../../addrbook.xml \
@@ -15,8 +21,11 @@ sylpheed-claws-manual.pdf: \
        ../../keyboard.xml \
        ../../plugins.xml \
        ../../starting.xml \
-       ../../sylpheed-claws-manual.xml 
-       -sh ../../../xml2pdf ../../../dtd/manual.xsl ../../sylpheed-claws-manual.xml
+       ../../claws-mail-manual.xml 
+       -$(DOCBOOK2PDF) -o . "$(srcdir)/../../claws-mail-manual.xml"
        
 maintainer-clean:
-       -rm sylpheed-claws-manual.pdf sylpheed-claws-manual.fo sylpheed-claws-manual.xsl
+       -rm claws-mail-manual.pdf claws-mail-manual.fo claws-mail-manual.xsl
+endif
+
+.PHONY: test