Use pre-defined make variables instead of hardcoded docbook2X and sed commands.
[claws.git] / manual / de / dist / txt / Makefile.am
index 1ad3a0a9b902654d8bb66e327172088bad9ab03f..51eca84f108d38ce3af3f46cb7db39716bbf872d 100644 (file)
@@ -1,3 +1,9 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
+if MANUAL_TXT
 EXTRA_DIST=claws-mail-manual.txt
 manualde_DATA=claws-mail-manual.txt
 manualdedir=$(manualdir)/de
@@ -16,7 +22,10 @@ claws-mail-manual.txt: \
        ../../plugins.xml \
        ../../starting.xml \
        ../../claws-mail-manual.xml 
-       -docbook2txt -o . ../../claws-mail-manual.xml
+       -$(DOCBOOK2TXT) -o . ../../claws-mail-manual.xml
        
 maintainer-clean:
        -rm claws-mail-manual.txt
+endif
+
+.PHONY: test