Use pre-defined make variables instead of hardcoded docbook2X and sed commands.
[claws.git] / manual / de / dist / html / Makefile.am
index 4b88e1d48a4b1432f428e0907a9bc4ac262b6321..391a8ab7314d9877a85854a59d864ed5fe7a2856 100644 (file)
@@ -1,5 +1,6 @@
-# Makefile.am for "manual/de/dist/html" directory
-# This file is part of Claws Mail package.
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
 if MANUAL_HTML
@@ -21,12 +22,14 @@ claws-mail-manual.html: \
        ../../plugins.xml \
        ../../starting.xml \
        ../../claws-mail-manual.xml 
-       -env SP_ENCODING=xml docbook2html -u -o . \
+       -SP_ENCODING=xml $(DOCBOOK2HTML) -u -o . \
                ../../claws-mail-manual.xml
-       -mv claws-mail-manual.html claws-mail-manual.html.raw
-       -sed 's,^><META,><META http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\"><META,' < claws-mail-manual.html.raw > claws-mail-manual.html
+       -mv -f claws-mail-manual.html claws-mail-manual.html.raw
+       -$(SED) 's,^><META,><META http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\"><META,' < claws-mail-manual.html.raw > claws-mail-manual.html
        
 maintainer-clean:
        -rm claws-mail-manual.html
        -rm claws-mail-manual.html.raw
 endif
+
+.PHONY: test