2005-10-03 [paul] 1.9.14cvs67
[claws.git] / doc / manual / en / sylpheed-4.html
index a6b1b053d8ba19724ca5862d4ce0645beae2b6e9..92dd540615a83d67d90740735af32325f7912585 100644 (file)
@@ -2,7 +2,7 @@
 <html>
 <head>
   <meta name="GENERATOR" content="LinuxDoc-Tools 0.9.21">
-  <title>Sylpheed User's Manual: Installation.</title>
+  <title>Sylpheed-Claws User's Manual: Installation.</title>
   <link href="sylpheed-5.html" rel="next">
   <link href="sylpheed-3.html" rel="previous">
   <link href="sylpheed.html#toc4" rel="contents">
@@ -46,139 +46,22 @@ and
 (for Palm addressbook use)</li>
   <li><a href="http://libetpan.sourceforge.net">Libetpan</a> (for IMAP4
 support)</li>
-  <li>libgnomeprint(ui) (for real printing support)</li>
-  <li>the equivalent of GTK+-devel and Xfree86-devel. (Otherwise
-./configure will fail.)</li>
+  <li>libgnomeprint(ui) (for extended printing support)</li>
+  <li><a href=http://aspell.sourceforge.net/>Aspell</a> (for spell checker support)</li>
+  <li><a href=http://spamassassin.org/>SpamAssassin</a> (for SpamAssassin plugin support)</li>
+  <li><a href=http://clamav.sourceforge.net/>Clam AntiVirus</a> (for Clam AntiVirus plugin support)</li>
+  <li><a href=http://www.dillo.org/>Dillo</a> (for Dillo HTML viewer plugin support)</li>
+  <li><a href=http://helm.cs.unibo.it/mml-widget/>GtkMathView</a> (for MathML viewer plugin support)</li>
 </ul>
 <p></p>
-<p>Notice: Sylpheed may be unstable depending on the environment.
-Please use the newest version of libraries if possible.</p>
-<h2><a name="ss4.2">4.2</a> <a href="sylpheed.html#toc4.2">Environments
-known as valid for Sylpheed</a>
-</h2>
-<p>
-</p>
-<ul>
-  <li>Debian GNU/Linux unstable (sid) (glibc 2.2.5) (development
-environment) </li>
-  <li>Debian GNU/Linux testing (woody) (glibc 2.2.5)</li>
-  <li>Debian GNU/Linux 2.2 (potato) (glibc 2.1.3) </li>
-  <li>Kondara MNU/Linux (glibc 2.1.x) </li>
-  <li>Kondara MNU/Linux 1.2</li>
-  <li>Kondara MNU/Linux 2.0</li>
-  <li>Vine Linux 1.1 (glibc 2.0.x + libwcsmbs) </li>
-  <li>Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC) </li>
-  <li>Vine Linux 2.1 </li>
-  <li>Vine Linux 2.1.5</li>
-  <li>Laser5 Linux 6.0 (glibc 2.1.x)</li>
-  <li>Laser5 Linux 6.2 (glibc 2.1.x)</li>
-  <li>Laser5 Linux 6.4 (glibc 2.1.x)</li>
-  <li>TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs) </li>
-  <li>TurboLinux 6.0 (glibc 2.1.2) </li>
-  <li>TurboLinux 7.0 (glibc 2.2.x) </li>
-  <li>Miracle Linux Standard Edition Version1.0 </li>
-  <li>Miracle Linux for PostgreSQL Version1.0 </li>
-  <li>Miracle Linux for Samba Version1.0 </li>
-  <li>RedHat Linux 5.2 (glibc 2.0.7) </li>
-  <li>RedHat Linux 6.0 </li>
-  <li>RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x) </li>
-  <li>RedHat Linux 6.2 / 6.2J (glibc 2.1.x) </li>
-  <li>RedHat Linux 7.0 / 7.0J </li>
-  <li>RedHat Linux 7.1</li>
-  <li>RedHat Linux 7.2</li>
-  <li>LinuxPPC2000 + Yukikaze(Japanization kit) </li>
-  <li>Linux2000G (Intel, PowerPC) </li>
-  <li>HOLON Linux 2.0 (Intel / PPC) </li>
-  <li>Linux for PPC Japanese Edition 2.0 (glibc 2.1.x) </li>
-  <li>Linux for PPC Japanese Edition 3.0 (glibc 2.1.x) </li>
-  <li>Linux MLD4</li>
-  <li>Linux MLD5 </li>
-  <li>Plamo Linux 2.0 </li>
-  <li>Plamo Linux 2.1</li>
-  <li>Slackware 7.0 </li>
-  <li>Slackware 7.1 </li>
-  <li>Slackware 8.0 </li>
-  <li>Linux Mandrake 7.0</li>
-  <li>Linux Mandrake 7.1</li>
-  <li>Linux Mandrake 7.2</li>
-  <li>Linux Mandrake 8.0</li>
-  <li>Linux Mandrake 8.1</li>
-  <li>SuSE Linux 6.3 (glibc 2.1.2) </li>
-  <li>SuSE Linux 6.4</li>
-  <li>SuSE Linux 7.0</li>
-  <li>SuSE Linux 7.1</li>
-  <li>SuSE Linux 7.2</li>
-  <li>SuSE Linux 7.3</li>
-  <li>OpenLinux 2.3 (glibc 2.1.1 -&gt; 2.1.3) </li>
-  <li>Caldera OpenDesktop 2.4 </li>
-  <li>Caldera Workstation 3.1</li>
-  <li>Conectiva Linux 4.0</li>
-  <li>Conectiva Linux 5.0</li>
-  <li>Conectiva Linux 7.0</li>
-  <li>Vector Linux 1.5 </li>
-  <li>Yellow Dog Linux 2.0 (glibc 2.2.1)</li>
-  <li>Yellow Dog Linux 2.1 (PowerPC)</li>
-  <li>ASP Linux 7.2 (glibc 2.2.4)</li>
-  <li>Redmond Linux (Lycoris)</li>
-</ul>
-<p></p>
-<p>
-</p>
-<ul>
-  <li>FreeBSD release 3.2</li>
-  <li>FreeBSD release 3.4</li>
-  <li>FreeBSD release 4.0</li>
-  <li>FreeBSD release 4.1</li>
-  <li>FreeBSD release 4.2</li>
-  <li>FreeBSD release 4.3</li>
-  <li>FreeBSD release 4.4</li>
-  <li>FreeBSD release 4.5</li>
-  <li>FreeBSD release 5.0</li>
-  <li>NetBSD 1.4.2 </li>
-  <li>NetBSD 1.5 + XPG4DL </li>
-  <li>NetBSD 1.5.1</li>
-  <li>NetBSD 1.5.2</li>
-  <li>OpenBSD 2.7 </li>
-  <li>OpenBSD 2.8 (i386) </li>
-  <li>OpenBSD 2.9</li>
-  <li>OpenBSD 3.0</li>
-  <li>BSD/OS 4.0.1 </li>
-</ul>
-<p></p>
-<p>
-</p>
-<ul>
-  <li>Solaris 2.5</li>
-  <li>Solaris 2.5.1</li>
-  <li>Solaris 2.6</li>
-  <li>Solaris 7</li>
-  <li>Solaris 8</li>
-  <li>IRIX 6.3</li>
-  <li>IRIX 6.4</li>
-  <li>IRIX 6.5, 6.5.8m</li>
-  <li>HP-UX 10.20 </li>
-  <li>HP-UX 11.00</li>
-  <li>HP-UX 11i</li>
-  <li>Tru64 Unix 5.0 (OSF1 v5.0)</li>
-  <li>SCO UnixWare 7</li>
-  <li>Mac OS X 10.1.3 (Darwin 5.3) + XDarwin (without XLocale support)
-+ libxpg4 </li>
-</ul>
-<p></p>
-<p>
-</p>
-<ul>
-  <li>Windows (MSVC + GTK+ for win32), in progress</li>
-</ul>
-<p></p>
-<h2><a name="ss4.3">4.3</a> <a href="sylpheed.html#toc4.3">Nuts and
+<h2><a name="ss4.2">4.2</a> <a href="sylpheed.html#toc4.2">Nuts and
 bolts of installation</a>
 </h2>
 <p>
 </p>
 <ul>
   <li>Download the latest version of the Sylpheed-Claws package from
-    <a href="http://claws.sylpheed.org/">http://claws.sylpheed.org/</a></li>
+    <a href="http://sourceforge.net/project/showfiles.php?group_id=25528&package_id=147457">SourceForge</a></li>
   <li>Untar the sourcefiles to a new directory</li>
   <li>tar -zxf sylpheed-claws-x.x.x.tar.gz (for tar.gz)</li>
   <li>tar -jxf sylpheed-claws-x.x.x.tar.bz2 (for tar.bz2) </li>
@@ -188,7 +71,7 @@ installation make files </li>
   <li>Run the 'make' program which will compile the sources. Do not
 proceed with this step if there are fatal errors in the previous step.
 Fatal errors indicate that things are missing in order to compile
-Sylpheed properly. </li>
+Sylpheed-Claws properly. </li>
 </ul>
 <p></p>
 <p>If the make process has completed, run "make install" (as root), to
@@ -202,20 +85,20 @@ Use <i>./configure --help</i> to list configuration syntax and options.</p>
 <p>
 </p>
 <ul>
-  <li><i>Jpilot</i>: to use you PDA addressbook with Sylpheed. You will
+  <li><i>Jpilot</i>: to use you PDA addressbook with Sylpheed-Claws. You will
 need the <i>Jpilot</i> library (and <i>pilot-link</i>, too).
 Enable this option with the <i>--enable-jpilot</i> configure switch.</li>
-  <li><i>GnuPG</i>: Sylpheed can encrypt and sign your messages (also
+  <li><i>GnuPG</i>: Sylpheed-Claws can encrypt and sign your messages (also
 decrypt
 and verify the signatures of the incoming messages) using GnuPG.
 GnuPG follows the OpenPGP standard and is compatible with PGP.
 To enable this feature, you need to install GnuPG and GPGME (interface
 library to GnuPG). This is automatically enabled if possible.</li>
-  <li><i>LDAP</i>: Sylpheed can connect to a LDAP server in order to
+  <li><i>LDAP</i>: Sylpheed-Claws can connect to a LDAP server in order to
 query mail addresses. To enable this feature you will need the
 OpenLDAP library.
 Enable this option with the <i>--enable-ldap</i> configure switch.</li>
-  <li><i>X-Faces</i>: you can create a small picture (of your face, or
+  <li><i>X-Face</i>: you can create a small picture (of your face, or
 of anything else) that will be sent in the header of your mails.
 This option is enabled if the compface library is found and
 can be disabled using the <i>--disable-compface</i> configure switch.</li>
@@ -233,23 +116,23 @@ not be part
 of your distribution. You can find them at the addresses listed at the
 beginning
 of this chapter, <a href="#option_libraries">here</a>.</p>
-<h2><a name="ss4.4">4.4</a> <a href="sylpheed.html#toc4.4">Installation
+<h2><a name="ss4.3">4.3</a> <a href="sylpheed.html#toc4.3">Installation
 on Linux using RPM</a>
 </h2>
 <p>As root, run the "rpm -Uvh " command on the RPM file you downloaded.
 As soon as this process is complete you can run Sylpheed-Claws as user.
 </p>
-<h2><a name="ss4.5">4.5</a> <a href="sylpheed.html#toc4.5">Installation
+<h2><a name="ss4.4">4.4</a> <a href="sylpheed.html#toc4.4">Installation
 on Debian Linux</a>
 </h2>
 <p>With an internet connection :</p>
 <p>apt-get install sylpheed-claws (to install it with a internet
 connection)</p>
 <p>Without internet connection, fetch the debian package for example on
-<a href="http://packages.debian.org/unstable/mail/sylpheed.html">http://packages.debian.org/unstable/mail/sylpheed-claws.html</a></p>
-<p>dpkg -i sylpheed-claws_x.x.x-1i386.deb</p>
-<p>dpkg --install sylpheed-claws_x.x.x-1i386.deb</p>
-<h2><a name="ss4.6">4.6</a> <a href="sylpheed.html#toc4.6">Installation
+<a href="http://packages.debian.org/unstable/mail/sylpheed-claws-gtk2.html">http://packages.debian.org/unstable/mail/sylpheed-claws-gtk2.html</a></p>
+<p>dpkg -i sylpheed-claws-gtk2_x.x.x-1i386.deb</p>
+<p>dpkg --install sylpheed-claws-gtk2_x.x.x-1i386.deb</p>
+<h2><a name="ss4.5">4.5</a> <a href="sylpheed.html#toc4.5">Installation
 on FreeBSD</a>
 </h2>
 <p>using the /stand/sysinstall tool (it is a menu-based interface) :</p>
@@ -258,10 +141,10 @@ on FreeBSD</a>
 then "sylpheed-claws" then, back to the "Packages" list, choose
 "Install"</p>
 <p>Using the ports</p>
-<p>Get the sylpheed port on :</p>
+<p>Get the Sylpheed-Claws port on :</p>
 <p>
 <a
- href="ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4.3-release/mail">ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4.3-release/mail</a></p>
+ href="ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/mail/">ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/mail/</a></p>
 <p>then, as root: pkg-add sylpheed-claws-x.x.x.tgz</p>
 <p>using the ports with compiling:</p>
 <p>first, update your port, fetch it on <a