2011-04-24 [paul] 3.7.9cvs15
[claws.git] / configure.ac
index 11eb8f6..cdd86f0 100644 (file)
@@ -9,10 +9,10 @@ PACKAGE=claws-mail
 dnl version number
 MAJOR_VERSION=3
 MINOR_VERSION=7
-MICRO_VERSION=8
+MICRO_VERSION=9
 INTERFACE_AGE=0
 BINARY_AGE=0
-EXTRA_VERSION=40
+EXTRA_VERSION=15
 EXTRA_RELEASE=
 EXTRA_GTK2_VERSION=
 
@@ -153,11 +153,11 @@ if test x"$_gcc_psign" = xyes ; then
        CFLAGS="$CFLAGS -Wno-pointer-sign"
 fi
 
-CFLAGS="$CFLAGS -Wall -Wno-pointer-sign"
+CFLAGS="$CFLAGS -Wall"
 
-if test $USE_MAINTAINER_MODE = yes; then
-       CFLAGS="-g -Wall -Wno-pointer-sign -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED -DGTK_DISABLE_SINGLE_INCLUDES"
-fi
+#if test $USE_MAINTAINER_MODE = yes; then
+#      CFLAGS="-g -Wall -Wno-pointer-sign -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED -DGTK_DISABLE_SINGLE_INCLUDES"
+#fi
 
 pthread_name=
 case "$target" in
@@ -283,7 +283,7 @@ if test x"$use_threads" = xyes ; then
                LIBS="$LIBS `$GLIB_CONFIG --libs gthread`"
                AC_DEFINE(USE_THREADS, 1, Whether to use multithread or not)
        else
-               AC_MSG_ERROR([Sylpheed requires GThread from GLib to use threading.])
+               AC_MSG_ERROR([Claws Mail requires GThread from GLib to use threading.])
        fi
 else
        AC_MSG_RESULT(no)