2010-08-25 [colin] 3.7.6cvs30
[claws.git] / autogen.sh
index 0b60d5c..33afc82 100644 (file)
@@ -38,8 +38,9 @@ if test "$1" = "--build-w32"; then
             --with-gpgme-prefix=${w32root} \
              --with-config-dir="Claws-mail" \
              --disable-openssl --disable-dillo-viewer-plugin \
-             --disable-nls --disable-libetpan --disable-aspell \
+             --disable-nls --disable-libetpan --disable-enchant \
              --disable-trayicon-plugin --disable-spamassassin-plugin \
+             --disable-bogofilter-plugin --disable-valgrind \
              PKG_CONFIG_LIBDIR="$w32root/lib/pkgconfig"
 
     rc=$?
@@ -47,6 +48,28 @@ if test "$1" = "--build-w32"; then
 fi
 # ***** end W32 build script *******
 
+bisonver=`bison --version`
+
+if [ "$bisonver" = "" ]; then
+       echo Bison is needed to compile Claws Mail CVS
+       exit 1
+fi
+
+flexver=`flex --version|sed "s/.* //"`
+
+if [ "$flexver" = "" ]; then
+       echo Flex 2.5.31 or greater is needed to compile Claws Mail CVS
+       exit 1
+else
+       flex_major=`echo $flexver|sed "s/\..*//"`
+       flex_minor=`echo $flexver|sed "s/$flex_major\.\(.*\)\..*/\1/"`
+       flex_micro=`echo $flexver|sed "s/$flex_major\.$flex_minor\.\(.*\)/\1/"`
+       if [ $flex_major -lt 2 -o $flex_minor -lt 5 -o $flex_micro -lt 31 ]; then
+               echo Flex 2.5.31 or greater is needed to compile Claws Mail CVS
+               exit 1
+       fi
+fi
+
 
 aclocal -I m4 \
   && libtoolize --force --copy \