* src/mimeview.[ch]
[claws.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index 14ed9d9..a52085c 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -9,16 +9,21 @@ on the other environment.
 
 It is confirmed to work on the following environments:
 
-o Debian GNU/Linux (woody/sid) (glibc 2.2.x)
+Linux
+
+o Debian GNU/Linux unstable (sid) (glibc 2.3.x)
+o Debian GNU/Linux 3.0 (woody) (glibc 2.2.5)
+o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
 o Kondara MNU/Linux (glibc 2.1.x)
+o Kondara MNU/Linux 1.2
+o Kondara MNU/Linux 2.0
 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
-o Vine Linux 2.1
-o Laser5 Linux 6.0 (glibc 2.1.x)
-o Laser5 Linux 6.2 (glibc 2.1.x)
-o Laser5 Linux 6.4 (glibc 2.1.x)
+o Vine Linux 2.1 / 2.1.5 / 2.5 / 2.6
+o Laser5 Linux 6.0 / 6.2 / 6.4 (glibc 2.1.x)
 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
 o TurboLinux 6.0 (glibc 2.1.2)
+o TurboLinux 7.0 (glibc 2.2.x)
 o Miracle Linux Standard Edition Version1.0
 o Miracle Linux for PostgreSQL Version1.0
 o Miracle Linux for Samba Version1.0
@@ -26,58 +31,67 @@ o RedHat Linux 5.2 (glibc 2.0.7)
 o RedHat Linux 6.0
 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
-o RedHat Linux 7.0 / 7.0J
-o RedHat Linux 7.1
+o RedHat Linux 7.0 / 7.0J / 7.1 / 7.2 / 7.3 / 8.0
 o LinuxPPC2000 + Yukikaze(Japanization kit)
 o Linux2000G (Intel / PPC)
 o HOLON Linux 2.0 (Intel / PPC)
 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
+o LinuxPPC Q4 2000 (glibc 2.1.x)
 o Linux MLD4
 o Linux MLD5
-o Plamo Linux 2.0
-o Slackware 7.1
-o Linux Mandrake 7.0
-o Linux Mandrake 7.1
-o Linux Mandrake 7.2
-o Linux Mandrake 8.0
-o SuSE Linux 6.3 (glibc 2.1.2)
-o SuSE Linux 6.4
-o SuSE Linux 7.0
-o SuSE Linux 7.1
-o SuSE Linux 7.2
+o Plamo Linux 2.0 / 2.1 / 2.2.x / 3.0
+o Slackware 7.0 / 7.1 / 8.0 / 8.1 / 9.0
+o Linux Mandrake 7.0 / 7.1 / 7.2 / 8.0 / 8.1 / 9.0 / 9.1
+o SuSE Linux 6.3 (glibc 2.1.2) / 6.4
+o SuSE Linux 7.0 / 7.1 / 7.2 / 7.3 / 8.0 / 8.1
 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
 o Caldera OpenDesktop 2.4
-o Conectiva Linux 4.0
-o Conectiva Linux 5.0
+o Caldera Workstation 3.1
+o Conectiva Linux 4.0 / 5.0 / 7.0 / 8.0
 o Vector Linux 1.5
+o Yellow Dog Linux 2.0 (glibc 2.2.1)
+o Yellow Dog Linux 2.1 (PowerPC)
+o ASP Linux 7.2 (glibc 2.2.4)
+o Redmond Linux (Lycoris)
+o Gentoo Linux 1.x
+
+BSD
+
 o FreeBSD 3.2-RELEASE
 o FreeBSD 3.4-RELEASE
-o FreeBSD 4.0-RELEASE
-o FreeBSD 4.1-RELEASE
-o FreeBSD 4.2-RELEASE
+o FreeBSD 4.0/4.1/4.2/4.3/4.4/4.5/4.6-RELEASE
 o FreeBSD 5.0-CURRENT
 o NetBSD 1.4.2
 o NetBSD 1.5 + XPG4DL
-o NetBSD 1.5.1
+o NetBSD 1.5.1 / 1.5.2
 o OpenBSD 2.7
 o OpenBSD 2.8 (i386)
-o OpenBSD 2.9
+o OpenBSD 2.9 / 3.0 / 3.1
 o BSD/OS 4.0.1
-o Solaris 2.5
-o Solaris 2.5.1
-o Solaris 2.6
-o Solaris 7
-o Solaris 8
-o IRIX 6.3
-o IRIX 6.5 6.5.8m
-o HP-UX 10.20
+
+Other commercial Unix
+
+o Solaris 2.5 / 2.5.1 / 2.6
+o Solaris 7 / 8 / 9
+o IRIX 6.3 / 6.4 / 6.5 6.5.8m
+o HP-UX 10.20 / 11.0 / 11i
 o Tru64 Unix 5.0 (OSF1 V5.0)
 o SCO UnixWare 7
-o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
-o Windows (cygwin + GTK+ for win32) (unstable)
+o Mac OS X 10.1.4 (Darwin 5.4) + XDarwin (without XLocale support) + libxpg4
+
+Others
+
+o Windows (MSVC + GTK+ for win32) (in progress)
 
-For installation, just type:
+Build it
+========
+
+Please make sure that gtk-devel and glib-devel (or similar) packages are
+installed before the compilation (you may also require flex (lex) and bison
+(yacc)).
+
+To compile and install, just type:
 
 % ./configure
 % make
@@ -85,27 +99,44 @@ For installation, just type:
 Password: [Enter password]
 # make install
 
-I recommend you to install gdk-pixbuf or gdk_imlib library before installing
-for built-in image view support, and libcompface for X-Face support.
+Additional libraries
+====================
+
+It is recommend to install gdk-pixbuf or gdk_imlib library before installing
+Sylpheed for built-in image view support, and compface library for X-Face
+support.
 
+You can get compface utilities and library from the following location:
 
-If you want to enable IPv6 support, append the option
---enable-ipv6 after ./configure.
+  http://freshmeat.net/projects/compface/
 
-If you want to enable GnuPG support, you need GPGME 0.2.1 or later, and
-GnuPG 1.0.4f or later. You can get them from the following location:
+Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
+If your system supports iconv() API, other character set / encoding
+(such as UTF-8, KOI8-R, and GB2312) will be also supported.
+
+GnuPG (>= 1.2.0) and GPGME (>= 0.3.10) are required for GnuPG (PGP) support
+(GPGME 0.4.x is not supported yet).
+
+You can get GnuPG and GPGME from the following location:
 
   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
-  ftp://ftp.gnupg.org/pub/gcrypt/devel/
+  ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
+
+Options for configure script
+============================
 
-and append the option --enable-gpgme after ./configure.
+  --disable-compface  disable compface (X-Face) support
+  --enable-openssl    SSL support (requires OpenSSL)
+  --enable-ipv6       IPv6 support
+  --enable-gpgme      GnuPG support (requires GPGME and GnuPG)
+  --enable-ldap       LDAP support
+  --enable-jpilot     JPilot support
 
-WARNING: the GnuPG support is still in the development stage, and it
-         may not work correctly. I suggest never to use a real key.
-         Please use sample keys.
+For other options, refer to ./configure --help .
 
 
-If the installation of Sylpheed failed, check all needed libraries are
-correctly installed. If it still failed, please send bug report to:
+If the installation of Sylpheed failed, check whether all the required
+libraries are correctly installed. If it still failed, please send bug
+report to:
 
   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>