update
[claws.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index dae82b2..17df779 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -66,9 +66,12 @@ o Caldera OpenDesktop 2.4
 o Caldera Workstation 3.1
 o Conectiva Linux 4.0
 o Conectiva Linux 5.0
+o Conectiva Linux 7.0
 o Vector Linux 1.5
 o Yellow Dog Linux 2.0 (glibc 2.2.1)
 o Yellow Dog Linux 2.1 (PowerPC)
+o ASP Linux 7.2 (glibc 2.2.4)
+o Redmond Linux (Lycoris)
 
 BSD
 
@@ -98,20 +101,27 @@ o Solaris 2.6
 o Solaris 7
 o Solaris 8
 o IRIX 6.3
+o IRIX 6.4
 o IRIX 6.5 6.5.8m
 o HP-UX 10.20
 o HP-UX 11.0
 o HP-UX 11i
 o Tru64 Unix 5.0 (OSF1 V5.0)
 o SCO UnixWare 7
-o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
+o Mac OS X 10.1.3 (Darwin 5.3) + XDarwin (without XLocale support) + libxpg4
 
 Others
 
-o Windows (cygwin + GTK+ for win32) (unstable)
+o Windows (cygwin + GTK+ for win32) (in progress)
 
+Build it
+========
 
-For installation, just type:
+Please make sure that gtk-devel and glib-devel (or similar) packages are
+installed before the compilation (you may also require flex (lex) and bison
+(yacc)).
+
+To compile and install, just type:
 
 % ./configure
 % make
@@ -119,9 +129,22 @@ For installation, just type:
 Password: [Enter password]
 # make install
 
+Additional libraries
+====================
+
 I recommend you to install gdk-pixbuf or gdk_imlib library before installing
-for built-in image view support, and libcompface for X-Face support.
+for built-in image view support, and compface library for X-Face support.
+
+You can get compface utilities and library from the following location:
+
+  http://freshmeat.net/projects/compface/
+
+Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
+If you want other character set / encoding (such as UTF-8, KOI8-R, and GB2312)
+to be supported, you have to install libjconv, which is a wrapper for
+iconv(). You can obtain it from the following location:
 
+  http://www.kondara.org/libjconv/index.html
 
 If you want to enable SSL support, append the option
 --enable-ssl after ./configure (you need OpenSSL).
@@ -133,7 +156,7 @@ If you want to enable GnuPG support, you need GPGME 0.2.3 or later, and
 GnuPG 1.0.6 or later. You can get them from the following location:
 
   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
-  ftp://ftp.gnupg.org/pub/gcrypt/devel/
+  ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
 
 and append the option --enable-gpgme after ./configure.