2006-03-05 [paul] 2.0.0cvs110
[claws.git] / src / plugins / pgpcore / Makefile.am
1 EXTRA_DIST = version.rc plugin.def sylpheed.def
2
3 if OS_WIN32
4
5 LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
6      `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
7      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
8
9 %.lo : %.rc
10         $(LTRCCOMPILE) -i $< -o $@
11
12 plugin_res = version.lo
13 plugin_res_ldflag = -Wl,.libs/version.o
14
15 export_symbols = -export-symbols $(srcdir)/plugin.def
16
17 plugin_deps = libsylpheed.a $(plugin_res) plugin.def
18
19 libsylpheed.a: sylpheed.def
20         $(DLLTOOL) --output-lib $@ --def $<
21
22 plugin_ldadd = -L . -lsylpheed
23
24 else
25 plugin_res =
26 plugin_res_ldflag =
27 export_symbols =
28 plugin_deps =
29 plugin_ldadd =
30 endif
31
32 if PLATFORM_WIN32
33 no_undefined = -no-undefined
34 else
35 no_undefined =
36 endif
37
38 if CYGWIN
39 cygwin_export_lib = -L$(top_builddir)/src -lsylpheed-claws
40 else
41 cygwin_export_lib =
42 endif
43
44 plugindir = $(pkglibdir)/plugins
45
46 plugin_LTLIBRARIES = pgpcore.la
47
48 pgpcore_la_SOURCES = \
49         passphrase.c \
50         plugin.c \
51         prefs_gpg.c \
52         select-keys.c \
53         sgpgme.c
54
55 pluginincludedir = $(pkgincludedir)/plugins/pgpcore
56 plugininclude_HEADERS = \
57         passphrase.h \
58         prefs_gpg.h \
59         select-keys.h \
60         sgpgme.h
61
62 pgpcore_la_LDFLAGS = \
63         $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
64         -avoid-version -module 
65 pgpcore_la_DEPENDENCIES = $(plugin_deps)
66 pgpcore_la_LIBADD = $(cygwin_export_lib) $(plugin_ldadd) \
67         $(GTK_LIBS) \
68         $(GPGME_LIBS)
69
70 INCLUDES = \
71         -I$(top_srcdir)/src \
72         -I$(top_srcdir)/src/common \
73         -I$(top_srcdir)/src/gtk
74
75 AM_CPPFLAGS = \
76         $(GLIB_CFLAGS) \
77         $(GTK_CFLAGS) \
78         $(GPGME_CFLAGS) \
79         -Wno-deprecated-declarations
80
81 clean-local:
82         rm -f libsylpheed.a
83