sync with sylpheed 0.6.4cvs18
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 o Debian GNU/Linux unstable (sid) (glibc 2.2.x)
13 o Debian GNU/Linux testing (woody) (glibc 2.2.x)
14 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
15 o Kondara MNU/Linux (glibc 2.1.x)
16 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
17 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
18 o Vine Linux 2.1
19 o Laser5 Linux 6.0 (glibc 2.1.x)
20 o Laser5 Linux 6.2 (glibc 2.1.x)
21 o Laser5 Linux 6.4 (glibc 2.1.x)
22 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
23 o TurboLinux 6.0 (glibc 2.1.2)
24 o Miracle Linux Standard Edition Version1.0
25 o Miracle Linux for PostgreSQL Version1.0
26 o Miracle Linux for Samba Version1.0
27 o RedHat Linux 5.2 (glibc 2.0.7)
28 o RedHat Linux 6.0
29 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
30 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
31 o RedHat Linux 7.0 / 7.0J
32 o RedHat Linux 7.1
33 o LinuxPPC2000 + Yukikaze(Japanization kit)
34 o Linux2000G (Intel / PPC)
35 o HOLON Linux 2.0 (Intel / PPC)
36 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
37 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
38 o LinuxPPC Q4 2000 (glibc 2.1.x)
39 o Linux MLD4
40 o Linux MLD5
41 o Plamo Linux 2.0
42 o Slackware 7.1
43 o Slackware 8.0
44 o Linux Mandrake 7.0
45 o Linux Mandrake 7.1
46 o Linux Mandrake 7.2
47 o Linux Mandrake 8.0
48 o Linux Mandrake 8.1
49 o SuSE Linux 6.3 (glibc 2.1.2)
50 o SuSE Linux 6.4
51 o SuSE Linux 7.0
52 o SuSE Linux 7.1
53 o SuSE Linux 7.2
54 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
55 o Caldera OpenDesktop 2.4
56 o Caldera Workstation 3.1
57 o Conectiva Linux 4.0
58 o Conectiva Linux 5.0
59 o Vector Linux 1.5
60 o Yellow Dog Linux 2.0 (glibc 2.2.1)
61 o FreeBSD 3.2-RELEASE
62 o FreeBSD 3.4-RELEASE
63 o FreeBSD 4.0-RELEASE
64 o FreeBSD 4.1-RELEASE
65 o FreeBSD 4.2-RELEASE
66 o FreeBSD 4.3-RELEASE
67 o FreeBSD 5.0-CURRENT
68 o NetBSD 1.4.2
69 o NetBSD 1.5 + XPG4DL
70 o NetBSD 1.5.1
71 o OpenBSD 2.7
72 o OpenBSD 2.8 (i386)
73 o OpenBSD 2.9
74 o BSD/OS 4.0.1
75 o Solaris 2.5
76 o Solaris 2.5.1
77 o Solaris 2.6
78 o Solaris 7
79 o Solaris 8
80 o IRIX 6.3
81 o IRIX 6.5 6.5.8m
82 o HP-UX 10.20
83 o Tru64 Unix 5.0 (OSF1 V5.0)
84 o SCO UnixWare 7
85 o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
86 o Windows (cygwin + GTK+ for win32) (unstable)
87
88
89 For installation, just type:
90
91 % ./configure
92 % make
93 % su
94 Password: [Enter password]
95 # make install
96
97 I recommend you to install gdk-pixbuf or gdk_imlib library before installing
98 for built-in image view support, and libcompface for X-Face support.
99
100
101 If you want to enable SSL support, append the option
102 --enable-ssl after ./configure (you need OpenSSL).
103
104 If you want to enable IPv6 support, append the option
105 --enable-ipv6 after ./configure.
106
107 If you want to enable GnuPG support, you need GPGME 0.2.3 or later, and
108 GnuPG 1.0.6 or later. You can get them from the following location:
109
110   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
111   ftp://ftp.gnupg.org/pub/gcrypt/devel/
112
113 and append the option --enable-gpgme after ./configure.
114
115 WARNING: the GnuPG support is still in the development stage, and it
116          may not work correctly. I suggest never to use a real key.
117          Please use sample keys.
118
119 For other options, refer to ./configure --help .
120
121
122 If the installation of Sylpheed failed, check all needed libraries are
123 correctly installed. If it still failed, please send bug report to:
124
125   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>