2005-05-09 [paul] 1.9.6cvs58
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 2.4.0 or higher to be compiled.
5
6 Build it
7 ========
8
9 Please make sure that gtk-devel and glib-devel (or similar) packages are
10 installed before the compilation (you may also require flex (lex) and bison
11 (yacc)).
12
13 To compile and install, just type:
14
15 % ./configure
16 % make
17 % su
18 Password: [Enter password]
19 # make install
20
21 Additional libraries
22 ====================
23 only needed if you require the additional functionality
24
25 compface
26     for X-Face support
27     http://freshmeat.net/projects/compface/
28 GnuPG (>= 1.2.1) and GPGME (>= 0.3.12 and < 0.4)
29     for GnuPG support
30     http://www.gnupg.org/
31     ftp://ftp.gnupg.org/gcrypt/gpgme/
32 OpenSSL (>= 0.9.7)
33     for SSL support
34     http://www.openssl.org/
35 OpenLDAP (>= 2.0.7)
36     for LDAP support
37     http://www.openldap.org/
38 Aspell (>= 0.50) (and dictionaries)
39     for spell-checker support
40     http://aspell.sourceforge.net/
41 J-Pilot
42     for J-Pilot support
43     http://www.jpilot.org/
44 SpamAssassin
45     for SpamAssassin plugin support
46     http://spamassassin.org/
47 Clam AntiVirus
48     for Clam AntiVirus plugin support
49     http://clamav.sourceforge.net/
50 Dillo (>= 0.7.0)
51     for Dillo HTML viewer plugin support
52     http://www.dillo.org/
53 GtkMathView (>= 0.4.2 and < 0.5)
54     for MathML viewer plugin support
55     http://helm.cs.unibo.it/mml-widget/
56   
57 Options for configure script
58 ============================
59   --with-config-dir=RCDIR           Local config dir (default: .sylpheed-gtk2)
60   --disable-compface                disable compface (X-Face) support
61   --disable-ipv6                    disable IPv6 support
62   --disable-openssl                 disable OpenSSL support
63   --enable-aspell                   GNU/aspell support
64   --enable-ldap                     LDAP support
65   --enable-jpilot                   JPilot support
66   --enable-crash-dialog             enable crash dialog
67   --disable-startup-notification    disable startup notification support
68   --disable-trayicon-plugin         Do not build System Tray Icon plugin
69   --enable-spamassassin-plugin      Build SpamAssassin plugin
70   --disable-pgpmime-plugin          Do not build PGP/MIME plugin
71   --disable-mathml-viewer-plugin    Do not build MathML-Viewer plugin
72   --disable-dillo-viewer-plugin     Do not build Dillo plugin
73   --disable-clamav-plugin           Do not build Clam AntiVirus plugin
74  
75 For other options, refer to ./configure --help .
76
77