sync with sylpheed 0.6.5cvs27
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 o Debian GNU/Linux unstable (sid) (glibc 2.2.x)
13 o Debian GNU/Linux testing (woody) (glibc 2.2.x)
14 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
15 o Kondara MNU/Linux (glibc 2.1.x)
16 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
17 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
18 o Vine Linux 2.1
19 o Laser5 Linux 6.0 (glibc 2.1.x)
20 o Laser5 Linux 6.2 (glibc 2.1.x)
21 o Laser5 Linux 6.4 (glibc 2.1.x)
22 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
23 o TurboLinux 6.0 (glibc 2.1.2)
24 o Miracle Linux Standard Edition Version1.0
25 o Miracle Linux for PostgreSQL Version1.0
26 o Miracle Linux for Samba Version1.0
27 o RedHat Linux 5.2 (glibc 2.0.7)
28 o RedHat Linux 6.0
29 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
30 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
31 o RedHat Linux 7.0 / 7.0J
32 o RedHat Linux 7.1
33 o RedHat Linux 7.2
34 o LinuxPPC2000 + Yukikaze(Japanization kit)
35 o Linux2000G (Intel / PPC)
36 o HOLON Linux 2.0 (Intel / PPC)
37 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
38 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
39 o LinuxPPC Q4 2000 (glibc 2.1.x)
40 o Linux MLD4
41 o Linux MLD5
42 o Plamo Linux 2.0
43 o Plamo Linux 2.1
44 o Slackware 7.0
45 o Slackware 7.1
46 o Slackware 8.0
47 o Linux Mandrake 7.0
48 o Linux Mandrake 7.1
49 o Linux Mandrake 7.2
50 o Linux Mandrake 8.0
51 o Linux Mandrake 8.1
52 o SuSE Linux 6.3 (glibc 2.1.2)
53 o SuSE Linux 6.4
54 o SuSE Linux 7.0
55 o SuSE Linux 7.1
56 o SuSE Linux 7.2
57 o SuSE Linux 7.3
58 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
59 o Caldera OpenDesktop 2.4
60 o Caldera Workstation 3.1
61 o Conectiva Linux 4.0
62 o Conectiva Linux 5.0
63 o Vector Linux 1.5
64 o Yellow Dog Linux 2.0 (glibc 2.2.1)
65 o Yellow Dog Linux 2.1 (PowerPC)
66 o FreeBSD 3.2-RELEASE
67 o FreeBSD 3.4-RELEASE
68 o FreeBSD 4.0-RELEASE
69 o FreeBSD 4.1-RELEASE
70 o FreeBSD 4.2-RELEASE
71 o FreeBSD 4.3-RELEASE
72 o FreeBSD 4.4-RELEASE
73 o FreeBSD 5.0-CURRENT
74 o NetBSD 1.4.2
75 o NetBSD 1.5 + XPG4DL
76 o NetBSD 1.5.1
77 o NetBSD 1.5.2
78 o OpenBSD 2.7
79 o OpenBSD 2.8 (i386)
80 o OpenBSD 2.9
81 o BSD/OS 4.0.1
82 o Solaris 2.5
83 o Solaris 2.5.1
84 o Solaris 2.6
85 o Solaris 7
86 o Solaris 8
87 o IRIX 6.3
88 o IRIX 6.5 6.5.8m
89 o HP-UX 10.20
90 o HP-UX 11.0
91 o HP-UX 11i
92 o Tru64 Unix 5.0 (OSF1 V5.0)
93 o SCO UnixWare 7
94 o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
95 o Windows (cygwin + GTK+ for win32) (unstable)
96
97
98 For installation, just type:
99
100 % ./configure
101 % make
102 % su
103 Password: [Enter password]
104 # make install
105
106 I recommend you to install gdk-pixbuf or gdk_imlib library before installing
107 for built-in image view support, and libcompface for X-Face support.
108
109
110 If you want to enable SSL support, append the option
111 --enable-ssl after ./configure (you need OpenSSL).
112
113 If you want to enable IPv6 support, append the option
114 --enable-ipv6 after ./configure.
115
116 If you want to enable GnuPG support, you need GPGME 0.2.3 or later, and
117 GnuPG 1.0.6 or later. You can get them from the following location:
118
119   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
120   ftp://ftp.gnupg.org/pub/gcrypt/devel/
121
122 and append the option --enable-gpgme after ./configure.
123
124 WARNING: the GnuPG support is still in the development stage, and it
125          may not work correctly. I suggest never to use a real key.
126          Please use sample keys.
127
128 For other options, refer to ./configure --help .
129
130
131 If the installation of Sylpheed failed, check all needed libraries are
132 correctly installed. If it still failed, please send bug report to:
133
134   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>