inc.c: remove two instances of 'GTK_EVENTS_FLUSH'
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 Linux
13
14 o Debian GNU/Linux unstable (sid) (glibc 2.3.x)
15 o Debian GNU/Linux 3.0 (woody) (glibc 2.2.5)
16 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
17 o Kondara MNU/Linux (glibc 2.1.x)
18 o Kondara MNU/Linux 1.2
19 o Kondara MNU/Linux 2.0
20 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
21 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
22 o Vine Linux 2.1 / 2.1.5 / 2.5 / 2.6
23 o Laser5 Linux 6.0 / 6.2 / 6.4 (glibc 2.1.x)
24 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
25 o TurboLinux 6.0 (glibc 2.1.2)
26 o TurboLinux 7.0 (glibc 2.2.x)
27 o Miracle Linux Standard Edition Version1.0
28 o Miracle Linux for PostgreSQL Version1.0
29 o Miracle Linux for Samba Version1.0
30 o RedHat Linux 5.2 (glibc 2.0.7)
31 o RedHat Linux 6.0
32 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
33 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
34 o RedHat Linux 7.0 / 7.0J / 7.1 / 7.2 / 7.3 / 8.0
35 o LinuxPPC2000 + Yukikaze(Japanization kit)
36 o Linux2000G (Intel / PPC)
37 o HOLON Linux 2.0 (Intel / PPC)
38 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
39 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
40 o LinuxPPC Q4 2000 (glibc 2.1.x)
41 o Linux MLD4
42 o Linux MLD5
43 o Plamo Linux 2.0 / 2.1 / 2.2.x / 3.0
44 o Slackware 7.0 / 7.1 / 8.0 / 8.1 / 9.0
45 o Linux Mandrake 7.0 / 7.1 / 7.2 / 8.0 / 8.1 / 9.0 / 9.1
46 o SuSE Linux 6.3 (glibc 2.1.2) / 6.4
47 o SuSE Linux 7.0 / 7.1 / 7.2 / 7.3 / 8.0 / 8.1
48 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
49 o Caldera OpenDesktop 2.4
50 o Caldera Workstation 3.1
51 o Conectiva Linux 4.0 / 5.0 / 7.0 / 8.0
52 o Vector Linux 1.5
53 o Yellow Dog Linux 2.0 (glibc 2.2.1)
54 o Yellow Dog Linux 2.1 (PowerPC)
55 o ASP Linux 7.2 (glibc 2.2.4)
56 o Redmond Linux (Lycoris)
57 o Gentoo Linux 1.x
58
59 BSD
60
61 o FreeBSD 3.2-RELEASE
62 o FreeBSD 3.4-RELEASE
63 o FreeBSD 4.0/4.1/4.2/4.3/4.4/4.5/4.6-RELEASE
64 o FreeBSD 5.0-CURRENT
65 o NetBSD 1.4.2
66 o NetBSD 1.5 + XPG4DL
67 o NetBSD 1.5.1 / 1.5.2
68 o OpenBSD 2.7
69 o OpenBSD 2.8 (i386)
70 o OpenBSD 2.9 / 3.0 / 3.1
71 o BSD/OS 4.0.1
72
73 Other commercial Unix
74
75 o Solaris 2.5 / 2.5.1 / 2.6
76 o Solaris 7 / 8 / 9
77 o IRIX 6.3 / 6.4 / 6.5 6.5.8m
78 o HP-UX 10.20 / 11.0 / 11i
79 o Tru64 Unix 5.0 (OSF1 V5.0)
80 o SCO UnixWare 7
81 o Mac OS X 10.1.4 (Darwin 5.4) + XDarwin (without XLocale support) + libxpg4
82
83 Others
84
85 o Windows (MSVC + GTK+ for win32) (in progress)
86
87 Build it
88 ========
89
90 Please make sure that gtk-devel and glib-devel (or similar) packages are
91 installed before the compilation (you may also require flex (lex) and bison
92 (yacc)).
93
94 To compile and install, just type:
95
96 % ./configure
97 % make
98 % su
99 Password: [Enter password]
100 # make install
101
102 Additional libraries
103 ====================
104
105 It is recommend to install gdk-pixbuf or gdk_imlib library before installing
106 Sylpheed for built-in image view support, and compface library for X-Face
107 support.
108
109 You can get compface utilities and library from the following location:
110
111   http://freshmeat.net/projects/compface/
112
113 Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
114 If your system supports iconv() API, other character set / encoding
115 (such as UTF-8, KOI8-R, and GB2312) will be also supported.
116
117 GnuPG (>= 1.2.0) and GPGME (>= 0.3.10) are required for GnuPG (PGP) support
118 (GPGME 0.4.x is not supported yet).
119
120 You can get GnuPG and GPGME from the following location:
121
122   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
123   ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
124
125 Options for configure script
126 ============================
127
128   --disable-compface  disable compface (X-Face) support
129   --enable-openssl    SSL support (requires OpenSSL)
130   --enable-ipv6       IPv6 support
131   --enable-gpgme      GnuPG support (requires GPGME and GnuPG)
132   --enable-ldap       LDAP support
133   --enable-jpilot     JPilot support
134
135 For other options, refer to ./configure --help .
136
137
138 If the installation of Sylpheed failed, check whether all the required
139 libraries are correctly installed. If it still failed, please send bug
140 report to:
141
142   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>