check local variable cache instead of text->line_start_cache
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 Linux
13
14 o Debian GNU/Linux unstable (sid) (glibc 2.2.x)
15 o Debian GNU/Linux testing (woody) (glibc 2.2.x)
16 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
17 o Kondara MNU/Linux (glibc 2.1.x)
18 o Kondara MNU/Linux 1.2
19 o Kondara MNU/Linux 2.0
20 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
21 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
22 o Vine Linux 2.1
23 o Vine Linux 2.1.5
24 o Laser5 Linux 6.0 / 6.2 / 6.4 (glibc 2.1.x)
25 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
26 o TurboLinux 6.0 (glibc 2.1.2)
27 o TurboLinux 7.0 (glibc 2.2.x)
28 o Miracle Linux Standard Edition Version1.0
29 o Miracle Linux for PostgreSQL Version1.0
30 o Miracle Linux for Samba Version1.0
31 o RedHat Linux 5.2 (glibc 2.0.7)
32 o RedHat Linux 6.0
33 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
34 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
35 o RedHat Linux 7.0 / 7.0J / 7.1 / 7.2 / 7.3
36 o LinuxPPC2000 + Yukikaze(Japanization kit)
37 o Linux2000G (Intel / PPC)
38 o HOLON Linux 2.0 (Intel / PPC)
39 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
40 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
41 o LinuxPPC Q4 2000 (glibc 2.1.x)
42 o Linux MLD4
43 o Linux MLD5
44 o Plamo Linux 2.0 / 2.1 / 2.2.x / 3.0-alpha
45 o Slackware 7.0 / 7.1 / 8.0
46 o Linux Mandrake 7.0 / 7.1 / 7.2 / 8.0 / 8.1
47 o SuSE Linux 6.3 (glibc 2.1.2)
48 o SuSE Linux 6.4
49 o SuSE Linux 7.0 / 7.1 / 7.2 / 7.3
50 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
51 o Caldera OpenDesktop 2.4
52 o Caldera Workstation 3.1
53 o Conectiva Linux 4.0 / 5.0 / 7.0 / 8.0
54 o Vector Linux 1.5
55 o Yellow Dog Linux 2.0 (glibc 2.2.1)
56 o Yellow Dog Linux 2.1 (PowerPC)
57 o ASP Linux 7.2 (glibc 2.2.4)
58 o Redmond Linux (Lycoris)
59 o Gentoo Linux 1.x
60
61 BSD
62
63 o FreeBSD 3.2-RELEASE
64 o FreeBSD 3.4-RELEASE
65 o FreeBSD 4.0/4.1/4.2/4.3/4.4/4.5/4.6-RELEASE
66 o FreeBSD 5.0-CURRENT
67 o NetBSD 1.4.2
68 o NetBSD 1.5 + XPG4DL
69 o NetBSD 1.5.1 / 1.5.2
70 o OpenBSD 2.7
71 o OpenBSD 2.8 (i386)
72 o OpenBSD 2.9 / 3.0 / 3.1
73 o BSD/OS 4.0.1
74
75 Other commercial Unix
76
77 o Solaris 2.5 / 2.5.1 / 2.6
78 o Solaris 7 / 8
79 o IRIX 6.3 / 6.4 / 6.5 6.5.8m
80 o HP-UX 10.20 / 11.0 / 11i
81 o Tru64 Unix 5.0 (OSF1 V5.0)
82 o SCO UnixWare 7
83 o Mac OS X 10.1.4 (Darwin 5.4) + XDarwin (without XLocale support) + libxpg4
84
85 Others
86
87 o Windows (MSVC + GTK+ for win32) (in progress)
88
89 Build it
90 ========
91
92 Please make sure that gtk-devel and glib-devel (or similar) packages are
93 installed before the compilation (you may also require flex (lex) and bison
94 (yacc)).
95
96 To compile and install, just type:
97
98 % ./configure
99 % make
100 % su
101 Password: [Enter password]
102 # make install
103
104 Additional libraries
105 ====================
106
107 It is recommend to install gdk-pixbuf or gdk_imlib library before installing
108 Sylpheed for built-in image view support, and compface library for X-Face
109 support.
110
111 You can get compface utilities and library from the following location:
112
113   http://freshmeat.net/projects/compface/
114
115 Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
116 If you want other character set / encoding (such as UTF-8, KOI8-R, and GB2312)
117 to be supported, you have to install libjconv, which is a wrapper for
118 iconv(). You can obtain it from the following location:
119
120   http://ghost.math.sci.hokudai.ac.jp/misc/libjconv/
121
122 GnuPG (>= 1.0.7) and GPGME (>= 0.3.5) are required for GnuPG (PGP) support.
123 You can get GnuPG and GPGME from the following location:
124
125   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
126   ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
127
128 Options for configure script
129 ============================
130
131   --disable-compface  disable compface (X-Face) support
132   --disable-jconv     disable libjconv support
133   --enable-ssl        SSL support (requires OpenSSL)
134   --enable-ipv6       IPv6 support
135   --enable-gpgme      GnuPG support (requires GPGME and GnuPG)
136   --enable-ldap       LDAP support
137   --enable-jpilot     JPilot support
138
139 For other options, refer to ./configure --help .
140
141
142 If the installation of Sylpheed failed, check whether all the required
143 libraries are correctly installed. If it still failed, please send bug
144 report to:
145
146   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>