53c947188741710d4d50ca5baf260b1bcf909f71
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 o Debian GNU/Linux unstable (sid) (glibc 2.2.x)
13 o Debian GNU/Linux testing (woody) (glibc 2.2.x)
14 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
15 o Kondara MNU/Linux (glibc 2.1.x)
16 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
17 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
18 o Vine Linux 2.1
19 o Laser5 Linux 6.0 (glibc 2.1.x)
20 o Laser5 Linux 6.2 (glibc 2.1.x)
21 o Laser5 Linux 6.4 (glibc 2.1.x)
22 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
23 o TurboLinux 6.0 (glibc 2.1.2)
24 o Miracle Linux Standard Edition Version1.0
25 o Miracle Linux for PostgreSQL Version1.0
26 o Miracle Linux for Samba Version1.0
27 o RedHat Linux 5.2 (glibc 2.0.7)
28 o RedHat Linux 6.0
29 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
30 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
31 o RedHat Linux 7.0 / 7.0J
32 o RedHat Linux 7.1
33 o LinuxPPC2000 + Yukikaze(Japanization kit)
34 o Linux2000G (Intel / PPC)
35 o HOLON Linux 2.0 (Intel / PPC)
36 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
37 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
38 o Linux MLD4
39 o Linux MLD5
40 o Plamo Linux 2.0
41 o Slackware 7.1
42 o Slackware 8.0
43 o Linux Mandrake 7.0
44 o Linux Mandrake 7.1
45 o Linux Mandrake 7.2
46 o Linux Mandrake 8.0
47 o SuSE Linux 6.3 (glibc 2.1.2)
48 o SuSE Linux 6.4
49 o SuSE Linux 7.0
50 o SuSE Linux 7.1
51 o SuSE Linux 7.2
52 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
53 o Caldera OpenDesktop 2.4
54 o Caldera Workstation 3.1
55 o Conectiva Linux 4.0
56 o Conectiva Linux 5.0
57 o Vector Linux 1.5
58 o FreeBSD 3.2-RELEASE
59 o FreeBSD 3.4-RELEASE
60 o FreeBSD 4.0-RELEASE
61 o FreeBSD 4.1-RELEASE
62 o FreeBSD 4.2-RELEASE
63 o FreeBSD 4.3-RELEASE
64 o FreeBSD 5.0-CURRENT
65 o NetBSD 1.4.2
66 o NetBSD 1.5 + XPG4DL
67 o NetBSD 1.5.1
68 o OpenBSD 2.7
69 o OpenBSD 2.8 (i386)
70 o OpenBSD 2.9
71 o BSD/OS 4.0.1
72 o Solaris 2.5
73 o Solaris 2.5.1
74 o Solaris 2.6
75 o Solaris 7
76 o Solaris 8
77 o IRIX 6.3
78 o IRIX 6.5 6.5.8m
79 o HP-UX 10.20
80 o Tru64 Unix 5.0 (OSF1 V5.0)
81 o SCO UnixWare 7
82 o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
83 o Windows (cygwin + GTK+ for win32) (unstable)
84
85
86 For installation, just type:
87
88 % ./configure
89 % make
90 % su
91 Password: [Enter password]
92 # make install
93
94 I recommend you to install gdk-pixbuf or gdk_imlib library before installing
95 for built-in image view support, and libcompface for X-Face support.
96
97
98 If you want to enable SSL support, append the option
99 --enable-ssl after ./configure (you need OpenSSL).
100
101 If you want to enable IPv6 support, append the option
102 --enable-ipv6 after ./configure.
103
104 If you want to enable GnuPG support, you need GPGME 0.2.3 or later, and
105 GnuPG 1.0.6 or later. You can get them from the following location:
106
107   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
108   ftp://ftp.gnupg.org/pub/gcrypt/devel/
109
110 and append the option --enable-gpgme after ./configure.
111
112 WARNING: the GnuPG support is still in the development stage, and it
113          may not work correctly. I suggest never to use a real key.
114          Please use sample keys.
115
116 For other options, refer to ./configure --help .
117
118
119 If the installation of Sylpheed failed, check all needed libraries are
120 correctly installed. If it still failed, please send bug report to:
121
122   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>