2008-08-21 [colin] 3.5.0cvs65
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 2.6.0 or higher to be compiled.
5
6 Build it
7 ========
8
9 Please make sure that gtk-devel and glib-devel (or similar) packages are
10 installed before the compilation (you may also require flex (lex) and bison
11 (yacc)).
12
13 To compile and install, just type:
14
15 % ./configure
16 % make
17 % su
18 Password: [Enter password]
19 # make install
20
21 To run, just type:
22
23 % claws-mail
24
25 Additional libraries
26 ====================
27 only needed if you require the additional functionality
28
29 Aspell (>= 0.50) (and dictionaries)
30     for spell-checker support
31     http://aspell.sourceforge.net/
32 compface
33     for X-Face support
34     http://freshmeat.net/projects/compface/
35 Dillo (>= 0.7.0)
36     for Dillo HTML viewer plugin support
37     http://www.dillo.org/
38 GnuPG (>= 1.2.1) and GPGME (>=  0.4.5)
39     for GnuPG plugin support
40     http://www.gnupg.org/
41     ftp://ftp.gnupg.org/gcrypt/gpgme/
42 J-Pilot
43     for J-Pilot support
44     http://www.jpilot.org/
45 libEtPan! (>= 0.52)
46     for IMAP4 support
47     http://www.etpan.org
48 libgnomeprint (>= 2.2)
49     for extended printing support
50     http://www.gnome.org
51 OpenLDAP (>= 2.0.7)
52     for LDAP support
53     http://www.openldap.org/
54 OpenSSL (>= 0.9.7)
55     for SSL support
56     http://www.openssl.org/
57 SpamAssassin
58     for SpamAssassin plugin support
59     http://spamassassin.apache.org/
60
61 Options for configure script
62 ============================
63 Most options are automatically enabled if the dependencies
64 are matched.
65
66   --with-config-dir=RCDIR           local config dir (default: ~/.claws-mail)
67   --disable-compface                disable compface (X-Face) support
68   --disable-ipv6                    disable IPv6 support
69   --disable-openssl                 disable OpenSSL support
70   --disable-libetpan                disable IMAP4 support
71   --disable-gnomeprint              disable libgnomeprint support
72   --disable-aspell                  disable GNU/aspell support
73   --disable-ldap                    disable LDAP support
74   --disable-jpilot                  disable JPilot support
75   --enable-crash-dialog             enable crash dialog
76   --disable-startup-notification    disable startup notification support
77   --disable-trayicon-plugin         do not build System Tray Icon plugin
78   --enable-spamassassin-plugin      build SpamAssassin plugin
79   --disable-pgpcore-plugin          do not build PGP/Core plugin
80   --disable-pgpmime-plugin          do not build PGP/MIME plugin
81   --disable-pgpinline-plugin        do not build PGP/Inline plugin
82   --disable-dillo-viewer-plugin     do not build Dillo plugin
83  
84 For other options, refer to ./configure --help .
85
86