199671383ba2fcf1496840321d66828b45381f49
[claws.git] / INSTALL
1 Installation
2 ============
3
4 This program requires GTK+ 1.2.6 or higher to be compiled.
5
6 This program is developed on Debian GNU/Linux (woody/sid)
7 (Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8 on the other environment.
9
10 It is confirmed to work on the following environments:
11
12 Linux
13
14 o Debian GNU/Linux unstable (sid) (glibc 2.2.x)
15 o Debian GNU/Linux testing (woody) (glibc 2.2.x)
16 o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
17 o Kondara MNU/Linux (glibc 2.1.x)
18 o Kondara MNU/Linux 1.2
19 o Kondara MNU/Linux 2.0
20 o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
21 o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
22 o Vine Linux 2.1
23 o Vine Linux 2.1.5
24 o Laser5 Linux 6.0 (glibc 2.1.x)
25 o Laser5 Linux 6.2 (glibc 2.1.x)
26 o Laser5 Linux 6.4 (glibc 2.1.x)
27 o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
28 o TurboLinux 6.0 (glibc 2.1.2)
29 o TurboLinux 7.0 (glibc 2.2.x)
30 o Miracle Linux Standard Edition Version1.0
31 o Miracle Linux for PostgreSQL Version1.0
32 o Miracle Linux for Samba Version1.0
33 o RedHat Linux 5.2 (glibc 2.0.7)
34 o RedHat Linux 6.0
35 o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
36 o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
37 o RedHat Linux 7.0 / 7.0J
38 o RedHat Linux 7.1
39 o RedHat Linux 7.2
40 o LinuxPPC2000 + Yukikaze(Japanization kit)
41 o Linux2000G (Intel / PPC)
42 o HOLON Linux 2.0 (Intel / PPC)
43 o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
44 o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
45 o LinuxPPC Q4 2000 (glibc 2.1.x)
46 o Linux MLD4
47 o Linux MLD5
48 o Plamo Linux 2.0
49 o Plamo Linux 2.1
50 o Slackware 7.0
51 o Slackware 7.1
52 o Slackware 8.0
53 o Linux Mandrake 7.0
54 o Linux Mandrake 7.1
55 o Linux Mandrake 7.2
56 o Linux Mandrake 8.0
57 o Linux Mandrake 8.1
58 o SuSE Linux 6.3 (glibc 2.1.2)
59 o SuSE Linux 6.4
60 o SuSE Linux 7.0
61 o SuSE Linux 7.1
62 o SuSE Linux 7.2
63 o SuSE Linux 7.3
64 o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
65 o Caldera OpenDesktop 2.4
66 o Caldera Workstation 3.1
67 o Conectiva Linux 4.0
68 o Conectiva Linux 5.0
69 o Vector Linux 1.5
70 o Yellow Dog Linux 2.0 (glibc 2.2.1)
71 o Yellow Dog Linux 2.1 (PowerPC)
72
73 BSD
74
75 o FreeBSD 3.2-RELEASE
76 o FreeBSD 3.4-RELEASE
77 o FreeBSD 4.0-RELEASE
78 o FreeBSD 4.1-RELEASE
79 o FreeBSD 4.2-RELEASE
80 o FreeBSD 4.3-RELEASE
81 o FreeBSD 4.4-RELEASE
82 o FreeBSD 5.0-CURRENT
83 o NetBSD 1.4.2
84 o NetBSD 1.5 + XPG4DL
85 o NetBSD 1.5.1
86 o NetBSD 1.5.2
87 o OpenBSD 2.7
88 o OpenBSD 2.8 (i386)
89 o OpenBSD 2.9
90 o OpenBSD 3.0
91 o BSD/OS 4.0.1
92
93 Other commercial Unix
94
95 o Solaris 2.5
96 o Solaris 2.5.1
97 o Solaris 2.6
98 o Solaris 7
99 o Solaris 8
100 o IRIX 6.3
101 o IRIX 6.4
102 o IRIX 6.5 6.5.8m
103 o HP-UX 10.20
104 o HP-UX 11.0
105 o HP-UX 11i
106 o Tru64 Unix 5.0 (OSF1 V5.0)
107 o SCO UnixWare 7
108 o Mac OS X (Darwin 1.3) + Xtools (has locale problem)
109
110 Others
111
112 o Windows (cygwin + GTK+ for win32) (unstable)
113
114 Build it
115 ========
116
117 For installation, just type:
118
119 % ./configure
120 % make
121 % su
122 Password: [Enter password]
123 # make install
124
125 Additional libraries
126 ====================
127
128 I recommend you to install gdk-pixbuf or gdk_imlib library before installing
129 for built-in image view support, and compface library for X-Face support.
130
131 You can get compface utilities and library from the following location:
132
133   http://freshmeat.net/projects/compface/
134
135 Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
136 If you want other character set / encoding (such as UTF-8, KOI8-R, and GB2312)
137 to be supported, you have to install libjconv, which is a wrapper for
138 iconv(). You can obtain it from the following location:
139
140   http://www.kondara.org/libjconv/index.html
141
142 If you want to enable SSL support, append the option
143 --enable-ssl after ./configure (you need OpenSSL).
144
145 If you want to enable IPv6 support, append the option
146 --enable-ipv6 after ./configure.
147
148 If you want to enable GnuPG support, you need GPGME 0.2.3 or later, and
149 GnuPG 1.0.6 or later. You can get them from the following location:
150
151   ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
152   ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
153
154 and append the option --enable-gpgme after ./configure.
155
156 WARNING: the GnuPG support is still in the development stage, and it
157          may not work correctly. I suggest never to use a real key.
158          Please use sample keys.
159
160 For other options, refer to ./configure --help .
161
162
163 If the installation of Sylpheed failed, check all needed libraries are
164 correctly installed. If it still failed, please send bug report to:
165
166   Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>